Multiplier plusieurs cellules entre elles dans des matrices différentes

pierre75

XLDnaute Nouveau
Bonjour,

Comment multiplier plusieurs cellules entre elles dans plusieurs matrices différentes suivant des critères homogènes ?
exemples : CA = (Qtés x PU)Ent A+B+x
MN = ((Qtés x (PU - FGX))Ent A+B+x

cf fichier excel joint

Merci pour vos idées (avec sommeprod ou autres)

Cordialement,
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Supporter XLD
Re : Multiplier plusieurs cellules entre elles dans des matrices différentes

Bonjour,
Voir soluce (dont je ne suis pas fier) en pj : repose sur le fait que les lignes utilisées sont décalées de 1 ligne, ne permet pas d'utiliser des colonnes entières.
Code:
{=SOMME(SI(C6:C21="qtés";D6:D21*D7:D22;0);0)}
Formule matricielle à valider par ctrl+maj+enter pour faire apparaître les {}
Cordialement
 

Fichiers joints

pierre75

XLDnaute Nouveau
Re : Multiplier plusieurs cellules entre elles dans des matrices différentes

Bonjour,

Solution effectivement astucieuse, mais pose problème lorsque les lignes n'ont pas la même chronologie entre les diffrentes matrices (i.e. : les lignes vides ne sont pas importées, d'où un décalage dans les arguments, et une véritable soupe aux choux à la place du CA)

Merci tout de même pour la solution : je garde l'idée.

Si un expert avait une autre idée, je suis preneur. Sinon je passe par VBA.

Cordialement
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas