multiplier les cellules

cyriled

XLDnaute Nouveau
bonjour,
je souhaite multiplier une liste d'identifiant en multipliant chaque valeurs par 30 sur la même colonne,,a priori il faut passer par vba pour faire cela. Quelqu'un aurait=il une idée ?
 

Chris24

XLDnaute Impliqué
Supporter XLD
Bonjour

Tu inscris 30 dans une cellule

Sélection de cette cellule -> Edition Copier.
Sélection de ta colonne de valeurs-> Edition ->Collage spécial->Multiplication

Cdt
 

cyriled

XLDnaute Nouveau
déjà merci pour votre réponse qui répond à un besoin de liste courte, mais effectivement la liste de cellules à dupliquer est de plus de 100 items, c'est pourquoi j'image que vba est nécessaire. Qu'en pensez ?
 

job75

XLDnaute Barbatruc
Bonsoir cyriles, Chris24, JHA,

En VBA c'est assez simple :
Code:
Private Sub Worksheet_Change(ByVal Target As Range)
Dim duplicateur As Range, resu As Range, n&
Set duplicateur = [C2]: Set resu = [E2]
If Intersect(Target, duplicateur) Is Nothing Then Exit Sub
Application.ScreenUpdating = False
If duplicateur Then
    For n = 2 To [A1].CurrentRegion.Count
        Cells(n, 1).Copy resu.Resize(duplicateur)
        Set resu = resu(duplicateur + 1)
    Next
End If
resu.Resize(Rows.Count - resu.Row + 1).Clear
End Sub
Le cellules sont dupliquées avec leur format.

Il y aura bug si le résultat dépasse les limites de la feuille.

Fichier joint.

A+
 

Fichiers joints

job75

XLDnaute Barbatruc
Re,

Une solution simple avec cette formule en E2 à tirer vers le bas :
Code:
=""&INDEX(A:A;2+ENT((LIGNE()-2)/C$2))
Fichier joint, j'ai mis 100 données en colonne A et la colonne E est colorée par alternance grâce à une MFC.

Bonne fin de soirée.
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour le fil, le forum,

Formule en E2 pour le cas où C2 est vide dans ce fichier (1 bis) :
Code:
=SI(C$2;""&INDEX(A:A;2+ENT((LIGNE()-2)/C$2));"")
Bonne journée.
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas