Autres multiple

chilo

XLDnaute Occasionnel
Bonjour le forum
je sollicite votre aide pour solutionner un petit problème
Je souhaite trouver u multiple d'un nombre en vba excel 2007


La ligne A va de 1 à plus de 600000
Les recherches effectuées ne répondent pas au résultat souhaité
alors j'ai simplement pensé à vous
je vous remercie par avance pour l'aide
Bonne journée
 

Fichiers joints

xUpsilon

XLDnaute Impliqué
Bonjour,

Je ne comprends pas ce que tu souhaites.
Tout d'abord A est une colonne pas une ligne, parle t'on de la meme chose ?
Ensuite, que cherches tu ? Voici un exemple de ce que j'ai compris : liste 3 12 42 49 55 70, tu cherches le nombre de multiples de 7, ça va te renvoyer 3 car il y a 3 multiples de 7 dans la liste. Est-ce que c'est ça que tu souhaites faire ?

Bonne continuation
 

chilo

XLDnaute Occasionnel
Bonjour,

Je ne comprends pas ce que tu souhaites.
Tout d'abord A est une colonne pas une ligne, parle t'on de la meme chose ?
Ensuite, que cherches tu ? Voici un exemple de ce que j'ai compris : liste 3 12 42 49 55 70, tu cherches le nombre de multiples de 7, ça va te renvoyer 3 car il y a 3 multiples de 7 dans la liste. Est-ce que c'est ça que tu souhaites faire ?

Bonne continuation
Bonsoir le forum, Bonsoir Upsilon

Effectivement Je voulais dire Colonne A

Ce que je souhaite, en colonne de 1 a près de 550000

de cette colonne, je voudrais trouver un multiple quelconque en fonction du besoin
Par exemple un multiple de 1802 ou 1500
avec excel 2007

Merci
 

job75

XLDnaute Barbatruc
Bonsoir chilo, xUpsilon,

Cette formule matricielle donnera le numéro de ligne du 1er multiple de 1082 différent de zéro :
VB:
=EQUIV(1;(A1:A1000000<>0)*NON(MOD(A1:A1000000;1082));0)
A valider par Ctrl+Maj+Entrée.

Bien sûr on peut remplacer 1082 par la référence d'une cellule.

A+
 

chilo

XLDnaute Occasionnel
Bonsoir le forum, Bonsoir Upsilon

Effectivement Je voulais dire Colonne A

Ce que je souhaite, en colonne de 1 a près de 550000

de cette colonne, je voudrais trouver un multiple quelconque en fonction du besoin
Par exemple un multiple de 1802 ou 1500
avec excel 2007

Merci
Merci bien JB
Je vais l'essayeer
et je reviens
merci
 

chilo

XLDnaute Occasionnel
Merci bien JB
Je vais l'essayeer
et je reviens
merci
Rebonsoir JOB75

Désolé Job75, je t'ai appelé JB, par réflexe j'ai un ami que j'appelle JB

J'ai essayé mais j'ai un N/A qui s'affiche

Par contre j'ai trouvé une façon qui me convient
mais il s'arrête à mi parcourt c'est à 4200 (le paresseux)
si tu pouvais me le modifier,
ce sera sympathique de ta part

Dim c As Range, dl As Integer

Application.ScreenUpdating = False

dl = Sheets("Feuil1").Range("A" & Rows.Count).End(xlUp).Row 'dernière ligne de la colonne A

For Each c In Range("A7:A" & dl) 'de A7 à la dernière ligne
c.Interior.ColorIndex = xlNone 'on efface les couleurs
c.Offset(0, 5).ClearContents 'efface les données en F

If Range("C1") <> "" And Range("C1") <> 0 Then 'si C1 nest pas vide et différent de 0
If c.Value Mod Range("C1") = 0 Then 'si multiple de C1
c.Interior.ColorIndex = 7 'couleur violet
c.Offset(0, 5) = "ok" 'ok en F
End If
Else
c.Interior.ColorIndex = xlNone 'sinon pas de couleur
End If
Next c

Application.ScreenUpdating = True

End Sub
Merci pour ton aide
 

Spinzi

XLDnaute Impliqué
Bonsoir chilo,

pour ton code, vérifie que toutes les cellules de ta colonne A soient bien remplies jusqu'à la dernière ligne.

Spinzi
 

job75

XLDnaute Barbatruc
Bonsoir, salut Spinzi,

Je ne vais sûrement pas utiliser du VBA pour un truc aussi simple.

Ma formule du post #4 va très bien mais vous ne savez peut-être pas la valider matriciellement.

Pour la valider matriciellement il faut cliquer dans la barre de formule et appuyer simultanément sur les touches Ctrl+Maj+Entrée.

Fichier joint.

A+
 

Fichiers joints

chilo

XLDnaute Occasionnel
Bonsoir, salut Spinzi,

Je ne vais sûrement pas utiliser du VBA pour un truc aussi simple.

Ma formule du post #4 va très bien mais vous ne savez peut-être pas la valider matriciellement.

Pour la valider matriciellement il faut cliquer dans la barre de formule et appuyer simultanément sur les touches Ctrl+Maj+Entrée.

Fichier joint.

A+
Merci Job75

Je vous remercie pour l'aide

Bonne soirée à tous
 

job75

XLDnaute Barbatruc
Bonjour Konte94,

A priori le plus simple est d'utiliser une Mise en forme conditionnelle (MFC) pour colorer les cellules :
VB:
=NON(MOD(A1;3))
la 1ère cellule du tableau étant en A1.

A+
 

Ikito

XLDnaute Occasionnel
Oui, il y a une macro pour tout.
Envoie nous un fichier avec les données que tu veux traiter et le résultat que tu souhaites obtenir.
 

Konte94

XLDnaute Junior
Oui, il y a une macro pour tout.
Envoie nous un fichier avec les données que tu veux traiter et le résultat que tu souhaites obtenir.
C'est cet exercice ci-dessous:
1°) Faire un programme VBA qui génère sur une feuille Excel un tableau de n lignes et de m colonnes contenant les nombres multiples du chiffre 3. Exple 0, 3, 6, 9…
Les tailles n et m sont récupérées par le programme.
2°) Créer deux boutons (CREER TABLEAU et EFFACER TABLEAU) qui vont créer et effacer le tableau.
 

job75

XLDnaute Barbatruc
C'est curieux qu'un débutant veuille à tout prix du VBA :rolleyes:

Voyez le fichier (2) et cette formule matricielle en A15 :
Code:
=SIERREUR(INDEX(A$1:A$10;PETITE.VALEUR(SI(NON(MOD(A$2:A$10;3));LIGNE(A$2:A$10));LIGNES(A$15:A15)));"")
A valider par Ctrl+Maj+Entrée et tirer à droite et vers le bas.

A+
 

Fichiers joints

Konte94

XLDnaute Junior
C'est curieux qu'un débutant veuille à tout prix du VBA :rolleyes:

Voyez le fichier (2) et cette formule matricielle en A15 :
Code:
=SIERREUR(INDEX(A$1:A$10;PETITE.VALEUR(SI(NON(MOD(A$2:A$10;3));LIGNE(A$2:A$10));LIGNES(A$15:A15)));"")
A valider par Ctrl+Maj+Entrée et tirer à droite et vers le bas.

A+
Job75 je comprends mais je me suis récemment inscrit pour une formation en vba mais cest un peu compliqué pour moi. Voici l'exercice que je veux résoudre:
1°) Faire un programme VBA qui génère sur une feuille Excel un tableau de n lignes et de m colonnes contenant les nombres multiples du chiffre 3. Exple 0, 3, 6, 9…
Les tailles n et m sont récupérées par le programme.
2°) Créer deux boutons (CREER TABLEAU et EFFACER TABLEAU) qui vont créer et effacer le tableau.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas