MOYENNE si formule dans les cellules

Josée

XLDnaute Nouveau
Bonjour,
Voici mon problème pour faire simple j'inscris en f4 la formule : =SOMME(B4:E4)/NBVAL(B4:E4)
étant donné que j'ai 4 trimestres et que je veux que la moyenne se calcule selon la donnée inscrite. Comme il y a une formule dans ma ligne B4:E4 j'ai le chiffre 0 qui est considéré dans ma moyenne...
 

Fichiers joints

CISCO

XLDnaute Barbatruc
Bonsoir

Cf. en pièce jointe. J'ai changé les formules dans B4:E4, F4, F2:F3 (différentes de celle dans F4).

@ plus
 

Fichiers joints

chris

XLDnaute Barbatruc
Bonjour à tous

Je ne comprends pas trop la raison de ces formules car MOYENNE ne prends que les nombres que contiennent les cellules et donc devrait suffire...
 

CISCO

XLDnaute Barbatruc
Bonsoir à tous, bonsoir Chris

Effectivement, on peut faire avec MOYENNE dans la colonne F, après avoir changé les formules dans la plage B4:E4.

@ plus
 

Fichiers joints

CISCO

XLDnaute Barbatruc
Bonjour

@ Victor21 : Oui et non : Si on a 4;12;0;0, les 0 provenant de l'absence de valeur dans les colonnes D et E, on doit avoir dans F4 la valeur 8, ce que donne bien MOYENNE.SI(B4:E4;">"&0). Par contre si l'un de ces 0, ou les deux , sont vraiment des 0, dans F4 on doit avoir 5,333 ou 4, et pas 8. A Josée de voir si ce cas peut se présenter.

@ plus
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour à tous.

Bonjour

@ Victor21 : Oui et non : Si on a 4;12;0;0, les 0 provenant de l'absence de valeur dans les colonnes D et E, on doit avoir dans F4 la valeur 8, ce que donne bien MOYENNE.SI(B4:E4;">"&0). Par contre si l'un de ces 0, ou les deux , sont vraiment des 0, dans F4 on doit avoir 5,333 ou 4, et pas 8. A Josée de voir si ce cas peut se présenter.

@ plus
Bien vu, CISCO :)
Je préconiserais même, en B4, à tecopier vers la droite :
=SI(OU(B2<>"";B3<>"");SOMME(B2:B3);" ")
 

Josée

XLDnaute Nouveau
Merci Cisco, ta 2e solution peut être appliquée, j'ai de nombreuses lignes dans mon document original et aucune chance que j'ai zéro comme donnée finale. En tout cas si ça se présente je regarderai pour autre chose... Franchement merci à tous pour votre participation, vous êtes tous géniaux!! ;) xx
 

CISCO

XLDnaute Barbatruc
Bonsoir

C'est peut être mieux d'utiliser la dernière proposition de Victor21
Code:
=SI(OU(B2<>"";B3<>"");SOMME(B2:B3);" ")
alors que moi j'avais utilisé
Code:
=SI(ET(B2<>"";B3<>"");SOMME(B2:B3);" ")
@ plus
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas