Microsoft 365 Moyenne pondérée dans la même colonne des données

Egruat

XLDnaute Occasionnel
Bonjour,

Dans une grande base de données, je dois effectuer une moyenne pondérée dans la même colonne que les données.

Comment puis-je faire ?

Exemple dans le fichier ci-joint

Merci de votre aide !
 

Pièces jointes

  • Classeur1.xlsx
    9 KB · Affichages: 12

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Egruat, Chris401,

pas sur d'avoir tout saisi mais bon en essai quand même suivant ton fichier exemple en cellule C11

VB:
=SOMMEPROD((B1:B10="qty")*C1:C10)

et en cellule C12

Code:
=SOMMEPROD(C1:C9*C2:C10)/C11


si ces formules ne donnent pas le résultat que tu attends remet nous ton exemple avec le résultat attendu

Cordialement
 

chris

XLDnaute Barbatruc
Bonjour à tous

Il faut vraiment jouer aux devinettes...
VB:
=SOMME(SI(B1:B10="Qty";C2:C10*C1:C9);0)/SOMME.SI.ENS(C1:C10;B1:B10;"Qty")
Matriciel pour ceux qui n'ont pas 365

Ou décomposé en 3
VB:
=SOMME.SI.ENS(C1:C10;B1:B10;"Qty")
=SOMME(SI(B1:B10="Qty";C2:C10*C1:C9);0)
=C12/C11
 
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re,
Bonjour Chris :),

Hum hum tu dis que le resultat doit être 1,78285714 et bien les formule que je t'ai fourni donne 1,78571429 la seulle différence viens de ta 3 ieme et 4 ieme décimale qui chez moi ne sont pas la

voir le fichier
 

Pièces jointes

  • Classeur1-3.xlsx
    14.8 KB · Affichages: 7

Jocelyn

XLDnaute Barbatruc
re bonjour

Merci Chris :) de m'avoir fait remarquer l'erreur de ma formule o_O donc la formule en C12 :

=SOMMEPROD(C1:C9*C2:C10)/C11

est à remplacer par :

=SOMMEPROD((A1:A9=A2:A10)*(C1:C9*C2:C10))/C11

le résultat est alors 1,78285714

Cordialement
 

Discussions similaires

Statistiques des forums

Discussions
294 371
Messages
1 938 081
Membres
188 641
dernier inscrit
pcayet