1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Modifier une formule

Discussion dans 'Forum Excel' démarrée par maval, 4 Décembre 2018.

  1. maval

    maval XLDnaute Barbatruc

    Inscrit depuis le :
    11 Mai 2012
    Messages :
    2059
    "J'aime" reçus :
    6
    Bonjour,

    J'ai un petit souci avec une formule. Voila ma formule:


    Code : Tout sélectionner

    Code (Text):
    =SI(ESTVIDE(C5);"";"<li class=""bloc""><a href=""../"&D5&"/"&B5&".html"" target=""myframe"" data-img=""img"&A5&"""data-txt="""&C5&""" id=""list-"&TEXTE(A5;"00")&""">"&C5&" </a></li>")
    Le résultat donne ceci

    ../Ariège /aigues_juntes.html" target="myframe" data-img="img1"data-txt="Aigues Juntes" id="list-01">Aigues Juntes </a></li>

    Mon souci est que entre Ariège et / j'ai un espace que je n'arrive pas à supprimer?

    Je vous remercie d'avance

    max
     
  2. Chargement...

    Discussions similaires - Modifier formule Forum Date
    XL 2010 VBA Modifier formule dans une macro Forum Excel 23 Novembre 2018
    Boucle chaque cellule : modifier référence dans formule (A1 par $A$1) Forum Excel 14 Novembre 2018
    XL 2013 Modifier une formule en VBA Forum Excel 7 Novembre 2018
    XL 2003 Modifier Formule en Macro Forum Excel 21 Août 2018
    XL 2010 Modifier une formule Forum Excel 2 Mai 2018

  3. ChTi160

    ChTi160 XLDnaute Barbatruc

    Inscrit depuis le :
    20 Février 2005
    Messages :
    5232
    "J'aime" reçus :
    147
    Travail/Loisirs :
    Pas grand Chose , faudrait pas que je me fatigue
    Habite à:
    Loin
    Utilise:
    Excel 2010 (PC)
    Bonjour max
    je ne vois pas trop dans la Formule ou se trouve le texte a traiter
    mais avec la fonction
    (Texte ou cellule ou variable)
    Tu supprimes les Espaces éventuels devant et derrière le texte , à voir !
    exemple
    Code (Visual Basic):
    <a href=""../"& TRIM(D5) &"/"& Trim(B5)&".html
    jean marie
     

Partager cette page