XL 2016 mise en forme conditionnelle si valeur de la cellule est comprise dans plage de 2 cellules

mam721

XLDnaute Junior
Bonjour à tous,

J'aimerais savoir comment mettre en place une règle de mise en forme conditionnelle en fonction de :
- Une valeur est elle comprise en entre une plage de valeur située dans 2 cellules différentes
- si oui, alors cellule rempli par X avec bordure et trame de fond vert
- si non, alors cellule rempli avec trame de fond grise.

je pensais faire :
=SI(ET(P1>=C1);(P1<=D1));"x")
mais Excel me le transforme en chaîne de caractère [ '=SI(ET(P1>=C1);(P1<=D1));"x") ] et non en formule.
alors je tente ca :
=SI(P1>=$C2;"X";SI(P1<=$D2;"X"))
mais Excel me donne toujours X

Puis de faire une regle de mise en forme :
_ si X alors couleur et bordeur
_ si vide alors grisé
Malheureusement, je n'arrive pas à me dépatouiller sur cette formule.

Question subsidiaire :
Est ce que la cellule de plage doit être strictement des nombres? ou peut elle être une chaîne de caractère genre MER01 ?

Vous trouverez ci joint, un exemple de tableau.

Je vous remercie.
 

Fichiers joints

Dernière édition:

mam721

XLDnaute Junior
Bonjour Jocelyn

C'est exactement ca.

J'ai pris note de la formule.
=SI(ET(DROITE($C2;2)*1<=DROITE(P$1;2)*1;DROITE($D2;2)*1>=DROITE(P$1;2)*1);"X";"")

Je ne comprends pas trop d'ou vient le *1.
Pourquoi faut il multiplier la valeur par *1 ?

Merci.
 

Jocelyn

XLDnaute Barbatruc
re,

comme tu l'avais un peu deviné il faut avoir des valeurs numériques or la fonction droite renvoie une valeur texte la multiplication par 1 permet de remettre les chiffres en numérique

Voila j'espère que l'explication est suffisante autrement n'hésites pas

Cordialement
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas