Office 365 mise en forme conditionnelle et règle particulière

chrisping76

XLDnaute Nouveau
Bonjour je dois proposer une solution de suivi des formations.
Je rencontre une difficulté pour intégrer un paramètre de suivi.
J'ai un délai maximal de 90 jours pour former le personnel:
-De 0 à 59 jours on entre la date d'entrée (colonne D) , le décompte démarre, la case temps de formation est verte
-De 60 à 90 jours on doit valider la personne, l'opérateur n'a pas ramené sa feuille , la case validation initiale (colonne E) est vide, un envoi d'email est généré pour avertir que l'on s'approche de l'échéance maximum, la case passe à l'orange.
- au delà de 90 jours on est dans le rouge, envoi d'email (un autre) généré qu'il ait ramené ou pas sa feuille.

Le soucis se fait pour le cas des personnes ramenant la feuille quand on est passé dans la case orange.
Si la personne a ramené sa feuille, on doit soit être vert soit délai <=90 jours) soit être rouge (délai > 90 jours), le cas orange ne doit plus se produire car la personne est validée dans les le délai requis.

Voici la formule que j'utilise pour les cases temps formation : =SI(E26="";AUJOURDHUI()-D26;E26-D26)


Capture présentation.PNG
Merci pour votre aide!!
 

frangy

XLDnaute Occasionnel
Bonjour,

A tester ...
MFC pour le rouge :
=$F26>=90

MFC pour l'orange :
=ET($F26>=60;$F26<90;$E26="")

MFC pour le vert :
=OU(ET($F26>=0;$F26<60);ET($E26;$F26<90))

Cordialement.
 

chrisping76

XLDnaute Nouveau
merci Frangy pour ton aide.
Je pense qu'on touche au but, mais j'ai un soucis dans le cas où l'opérateur est présent depuis plus de 60 jours, mais qu'il n'a pas ramené sa feuille de qualification (case de validation initiale restée vide): La case passe au vert alors qu'elle devrait être orange.
Ta solution fonctionne en revanche s'il a ramené le document.
 

frangy

XLDnaute Occasionnel
Bonjour,

De mon coté, je ne constate pas l'anomalie signalée.
Vérifie l'ordre de priorité des 3 MFC : Rouge, Orange, Vert.

Cordialement.
 

Fichiers joints

chrisping76

XLDnaute Nouveau
Effectivement le soucis était bien l'ordre des MFC.
Que dire d'autre qu'un grand MERCI!!!
Je suis alternant dans l'entreprise, je dois présenter ce fichier devant le comité de direction et c'était le dernier point problématique...
 

Discussions similaires


Haut Bas