Mise en forme conditionnelle cellules adjacentes

____Flo____

XLDnaute Nouveau
Bonjour,

J'ai un fichier Excel de type planning (exemple image ci-jointe).
Pour chaque mois j'ai 4 colonnes
  • colonne 1 : le numéro du jour,
  • colonne 2 : la première lettre du jour,
  • colonne 3 : une cellule vide dans laquelle je pourrais saisir le texte que je veux,
  • colonne 4 : qui indique le numéro de la semaine (et plus tard me permettra d'indiquer les vacances scolaires).

Via la mise en forme conditionnelle, j'ai pu mettre en couleur la colonne 1 afin de faire apparaître les week-ends et les jours fériés.

Ce que je souhaiterai faire c'est colorer de la même manière que la colonne 1, les colonnes 2, 3 et 4.
N'étant pas très familière avec VBA, je préférerai le faire sans utiliser VBA.

En sélectionnant la plage du mois et en appliquant presque les mêmes formules de mise en forme conditionnelle que celles que j'ai déjà fait pour la 1ère colonne, je sais que c'est faisable, mais c'est long et pas forcément simple à maintenir.

Est-ce qu'il existe quelque chose du type "colorie de la même manière les 3 colonnes à droite" ?

Merci d'avance pour vos réponses
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour ____Flo____, bienvenue sur XLD,

Avec une image on ne peut rien faire, joignez votre fichier Excel, sans données confidentielles.

A+
 

____Flo____

XLDnaute Nouveau
Merci JHA pour votre réponse.

Effectivement, la partie avec "$B2 bloque la colonne "B" mais pas la ligne" cela colore bien plusieurs cellules adjacentes mais dans mon cas cela colore également les mois d'à côté. Si je réplique la formule 12 fois en sélectionnant les mois plage plage, cela devrait fonctionner je pense.
Pensez-vous qu'il soit possible de le faire en 1 seule fois ?
 

Fichiers joints

job75

XLDnaute Barbatruc
Re, salut JHA,
Pensez-vous qu'il soit possible de le faire en 1 seule fois ?
Oui, voyez le fichier joint avec ces formules pour les 2 conditions de la MFC :
Code:
=SI(ESTNUM(A3);ET(A3>41000;JOURSEM(A3;2)>5))+SI(ESTNUM(DECALER(A3;;-1));ET(DECALER(A3;;-1)>41000;JOURSEM(DECALER(A3;;-1);2)>5))+SI(ESTNUM(DECALER(A3;;-2));ET(DECALER(A3;;-2)>41000;JOURSEM(DECALER(A3;;-2);2)>5))+SI(ESTNUM(DECALER(A3;;-3));ET(DECALER(A3;;-3)>41000;JOURSEM(DECALER(A3;;-3);2)>5))
Code:
=NB.SI(Paramètres!$E$3:$E$57;A3)+NB.SI(Paramètres!$E$3:$E$57;DECALER(A3;;-1))+NB.SI(Paramètres!$E$3:$E$57;DECALER(A3;;-2))+NB.SI(Paramètres!$E$3:$E$57;DECALER(A3;;-3))
A+
 

Fichiers joints

____Flo____

XLDnaute Nouveau
Merci.

Effectivement cela fonctionne très bien.
Et waou, quelle maîtrise !

Je vais prendre le temps de comprendre ces formules et je me permettrai de revenir vers vous si je ne comprends pas tout.

Bonne soirée
 

job75

XLDnaute Barbatruc
Bonjour Flo, JHA, le forum,

Dans ce fichier (2) ces 2 formules pour la MFC sont beaucoup plus simples :
Code:
=ET(N(DECALER(A3;;-MOD(COLONNE()-1;4)))>41000;JOURSEM(N(DECALER(A3;;-MOD(COLONNE()-1;4)));2)>5)

=NB.SI(Paramètres!$E$3:$E$57;DECALER(A3;;-MOD(COLONNE()-1;4)))
Bonne journée.
 

Fichiers joints

Discussions similaires


Haut Bas