Autres MFC

ALEA()

XLDnaute Junior
Bonjour,

J'espère que vous allez bien...
Je joins un fichier dans lequel je voudrais installer une MFC (nb communs avec une ligne de référence) et compter ces couleurs par ligne.

Merci de votre aide.

Alea()
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour ALEA()

Formule de la MFC sur A1:T12 =NB.SI($A$13:$T$13;A1)

Formule en U1 =SOMMEPROD(SIGNE(NB.SI(A$13:$T13;A1:T1)))

A+
 

Fichiers joints

ALEA()

XLDnaute Junior
Bonjour Job75, merci pour cette MFC et cette formule (que veut dire SIGNE ?)

Bonne soirée
 

job75

XLDnaute Barbatruc
Suivant que l'argument est positif, négatif ou nul la fonction SIGNE renvoie 1, -1 ou 0.
 

ALEA()

XLDnaute Junior
Merci pour votre réponse.

Le "sommeprod" m'a permis de calculer par rapport à cette ligne de référence 13.

Serait-il possible (base de données d'environ 500 lignes) de déterminer QUELLE ligne de référence donnerait un maximum de lignes avec un maximum de numéros communs ( donc avec cette ligne de référence à trouver?) en partant du bas de la base.

(Par formules, c'est impossible, il faudrait faire 500 colonnes juxtaposées de sommeprod et les compter!!)


Si vous avez une idée... Merci

Alea()
 

job75

XLDnaute Barbatruc
Utilisez cette formule matricielle :
Code:
=MAX(SI(U1:U12=MAX(U1:U12);LIGNE(U1:U12)))
à valider par Ctrl+Maj+Entrée.
 

ALEA()

XLDnaute Junior
Bonjour Job75, merci pour cette formule, toutefois, pour déterminer quelle ligne servira de référence, je dois faire autant de " sommeprod " que de lignes (500 environ), n'y a t-il pas plus simple? je joins un petit exemple.

Merci et bonne journée
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour ALEA(),
pour déterminer quelle ligne servira de référence, je dois faire autant de " sommeprod " que de lignes (500 environ), n'y a t-il pas plus simple?
Ce n'est pas compliqué avec ce fichier (2) et la formule en U1 à tirer à droite et vers le bas :
Code:
=SI(LIGNE()=COLONNE()-20;"";SOMMEPROD(SIGNE(NB.SI(DECALER($A$1:$T$1;COLONNE()-21;);$A1:$T1))))
A+
 

Fichiers joints

job75

XLDnaute Barbatruc
Cela dit avec ce fichier (3) une seule colonne suffit pour la formule en W1 :
Code:
=SOMMEPROD((LIGNE(A$1:T$6)<>LIGNE())*SIGNE(NB.SI(A1:T1;A$1:T$6)))
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas