XL 2013 MFC recherche de doublons dans 2 colonnes sans les cellules vides

pilou010

XLDnaute Junior
Bonjour,
Dans le fichier joint, une MFC pour identifier les doublons dans 2 colonnes qui fonctionne très bien. MFC Créée suite à une recherche sur le forum.
Par contre je ne trouve pas la solution pour que les cellules vides ne soient pas prises en compte ?

La formule dans la MFC : =SOMMEPROD(N($B$2:$B$11&$C$2:$C$11=$B2&$C2))>1
Si quelqu'un peut aussi m'expliquer la présence du N dans la formule ?

Merci
Pilou
 

Pièces jointes

  • Pilou016.xlsx
    9.4 KB · Affichages: 6

Jocelyn

XLDnaute Barbatruc
Re
Bonjour Etoto,

Il n'y a pas un seul test il faut qu'il y ai un doublon mais 2 ligne vide seront aussi considéré comme doublons donc pour éviter cela on ajoute le fait $B2&$C2 ne soit pas vide (ou egal à rien)

J'espère avoir été clair sinon n'hesite pas

Cordialement
 

Discussions similaires

Réponses
7
Affichages
303
Haut Bas