XL 2019 MFC pour une cellule

alexandre33260

XLDnaute Occasionnel
Bonjour, comment faire pour que dans une cellule A1 par exemple, si j'écris un nombre <100, la cellule écrive 100 Mo et si la valeur est >100, cela écrive 101 Go.
J'ai essayé avec les MFC, mais cela laisse un espace après le nombre sup à 100 mais cela n'écrit pas Mo.
Merci pour votre aide.
 

Phil69970

XLDnaute Impliqué
Bonjour Alexandre, Antoine, le forum

@alexandre33260 :
Tu as écris tout le contraire entre ton post 1 et ton post 3 !
j'écris un nombre <100, la cellule écrive 100 Mo et si la valeur est >100, cela écrive 101 Go.
(rajouter Go si <100), par contre si la valeur est sup à 100, cela doit écrire par exemple 412 Mo (rajouter Mo si >100).
Si tu veux une réponse correcte il faut savoir ce que tu veux exactement.

@Antoine44 :
Et la formule serait plutôt quelque chose comme ça :

=SI(A1<100; A1 & " Mo";A1 & " GO")

@Phil69970
 
Dernière édition:

Antoine44

XLDnaute Nouveau
Ok à partir de:
1000 Ko tu veux que ça apparaisse en 1,0 Mo
1000 Mo tu veux que ça apparaisse en 1,0 Go
1000 Go tu veux que ça apparaisse en 1,0 To

Mais tu veux aussi que:
si < à 100 Ko apparaisse 100Ko et que >= à 100Ko apparaisse 101Ko et cela à tout changement de centaine.
si < à 100 Mo apparaisse 100Mo et que >= à 100Mo apparaisse 101Mo et cela à tout changement de centaine.
si < à 100 Go apparaisse 100Go et que >= à 100Go apparaisse 101Go et cela à tout changement de centaine.

Le plus simple c'est que tu te définisses une façon systématique de rentrer tes valeurs en colonne A exemple: tu ne peux pas dire je vais mettre des 100, ect pour les Mo et des 1,7 pour les Go. il faut que tu restes sur la même échelle de valeur .

En colonne B to renseigne ton unité (Ko,Mo,Go,To) en fasse de chaque cellule de la colonne A.

En colonne C tu exploite la formule IFS (plusieurs si en version anglaise)
 

Membres actuellement en ligne

Statistiques des forums

Discussions
284 862
Messages
1 863 695
Membres
155 617
dernier inscrit
MoriSI
Haut Bas