XL 2010 Message alerte >30 jours

nabilexcel2007

XLDnaute Occasionnel
j'ai un fichier excel avec formule la formule fonctionne avec :=SI(ESTVIDE(E4);"";SI(H4>=30;"Alerte";"En cours"))

quand je rajoute cette formule : ;SI(F4="";"certificat conforme"). elle ne fonctionne pas!!



s'il ya une possiblilite a 22 jour cellule verte a 30 jours cellule rouge


Merci
 

Pièces jointes

  • retard.xlsx
    13.1 KB · Affichages: 3

Softmama

XLDnaute Accro
Bonjour,

Ce que vous souhaitez faire n'est pas très clair.
La fonction SI(...) utilise trois paramètres, séparés par des ;
Le premier est la condition à vérifier ; dans votre exemple vérifier si la cellule E4 est vide
Le deuxième montre quoi afficher si la condition est remplie (donc si E4 est bien vide). Dans votre exemple rien.
Le troisième montre quoi afficher si E4 contient des données (et dans votre exemple, si la valeur dépasse 30, il affiche Alerte, sinon En cours.

Le souci c'est que vous avez ajouté un quatrième paramètre, ce qui est incompréhensible pour Excel (et pour moi), vu que la fonction SI(...) n'en accepte que 3.

Il faudrait préciser ce que votre ajout est supposé faire ?
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Nabilexcel,
C'est vraiment dommage qu'après 183 messages, vous ne sachiez toujours pas dire bonjour en arrivant.
C'est pourtant une simple formule de politesse.

En PJ un essai avec le peu que j'ai compris :
Le point 1, j'ai tenté cela mais je ne suis pas sur que c'est ce que vous vouliez. A vous de l'adapter.
VB:
=SI(ESTVIDE(E3);"";SI(H3>=30;"Alerte";SI(F3="";"certificat conforme";"En cours")))
Le point 2, je suppose que c'est la colonne L qui est concernée. J'ai mis 3 MFC, <=22, >22 et <30, >30.
 

Pièces jointes

  • retard.xlsx
    12.8 KB · Affichages: 2

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour,
Toujours pas compris. Que signifie pour vous DATE ?
Un essai en PJ avec :
VB:
=SI(ESTVIDE(E3);"";SI(H3>=30;"Alerte";SI(OU(F3="";Tableau1[[#Cette ligne];[Date Réponse DEP]]>AUJOURDHUI());"En cours";"Certificat conforme")))
En bon français :
On met Alerte si délai entre Date Envoie DEP et aujourdhui est > 30 jours,
sinon si F3 est vide OU Date Réponse DEP > aujourdhui alors En cours,
sinon si F3 est non vide ET Date Réponse DEP< aujourdhui alors Certificat conforme.
 

Pièces jointes

  • retard (1).xlsx
    12.9 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
Pourriez vous expliqué ce que vous voulez obtenir ?
Comme je vous l'ai indiqué, il affiche "certificat conforme" si :
On met Alerte si délai entre Date Envoie DEP et aujourdhui est > 30 jours,
sinon si F3 est vide OU Date Réponse DEP > aujourdhui alors En cours,
sinon si F3 est non vide ET Date Réponse DEP< aujourdhui alors Certificat conforme.
Personne a de boule de cristal, donc on essaie avec ce dont on dispose d'infirmations.
 

Discussions similaires

Réponses
11
Affichages
546

Statistiques des forums

Discussions
286 621
Messages
1 877 549
Membres
160 769
dernier inscrit
Yudlo
Haut Bas