MATHS & EXCEL : Décomposition d'un nombre ?

Levis

XLDnaute Nouveau
Bonjour,
Y a-t-il une fonction sur excel pour décomposer un nombre en facteur de nombres premiers ?
Et surtout, comment donner la valuation p-adique d'un nombre ?
(Quand p est un nombre premier, par exemple p=3, la valuation 3-adique d'un nombre est son exposant pour 3 dans sa décomposition, par exemple la valuation 3-adique de 1134 est 4 car 1134=2*7*3^4)
Quelqu'un de fort en programmation excel pourrait-il me dire comment faire ?
Merci !
 
Dernière édition:

Levis

XLDnaute Nouveau
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Merci, et un dernier de chez dernier problème : je suis arrivé au bout des colonnes possibles (IV) et il me manque encore quelques dizaines de colonnes pour finir, comment en ajouter ? Merci
 
Dernière édition:

jeanpierre

Nous a quitté
Repose en paix
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Bonsoir Levis, le fil,

Rajouter des colonnes n'est pas possible sauf à passer sous Excel 2007 ou alors coller des feuilles à droite de l'écran (non je déc......)

Sinon revoir et travailler en lignes....

Bonne soirée et merci aux bonnes interventions sur ce fil...

Jean-Pierre
 

job75

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Re,

Merci, et un dernier de chez dernier problème : je suis arrivé au bout des colonnes possibles (IV) et il me manque encore quelques dizaines de colonnes pour finir, comment en ajouter ? Merci

Celle-la c'est la meilleure :D

Je vois 2 solutions :

1) Avec une scie circulaire vous faites une longue entaille dans le chassis de l'écran à droite et vous tapotez à gauche (peu recommandé)

2) Vous achetez Excel 2007 (recommandé).

Edit : ah mais non, je viens de tester !! L'entaille c'est à gauche, on tapote à droite !!

Allez bonne nuit.
 
Dernière édition:

job75

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Re, salut jeanpierre,

Coller des feuilles, mais c'est bien sûr.

En fait, et là je suis (presque) sérieux, cela devrait être possible en couplant un 2ème ordi avec le 1er.

Faites une recherche sur le partage d'écran.

A+
 

Levis

XLDnaute Nouveau
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Parce qu'il faut que les fonctions marchent sur l'autre onglet en même temps ça va être compliqué.
Alors pour économiser j'ai une idée mais je sais tjr pas comment faire :D

Il fautdrait que dans ma formule =SOMME(1*(MOD($A2;$EI2^LIGNE($A$1:$A$10))=0)) quand je l'étale vers la droite, "EI2" croisse vers le bas, c a d passe à EI3, etc au lieu de faire EJ2, EK2,...
Comment faire ? Merci :eek:
 

job75

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Bonjour Levis, le fil,

Il fautdrait que (...) quand je l'étale vers la droite, "EI2" croisse vers le bas, c a d passe à EI3, etc

Si la 1ère formule est entrée en B1, utilisez ceci :

Code:
=SOMME(1*(MOD($A2;[COLOR="Red"]DECALER($EI2;COLONNES($B1:B1)-1;)[/COLOR]^LIGNE($A$1:$A$10))=0))

Et tirez vers la droite, pas trop loin quand même :p

A+
 

ROGER2327

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Bonjour à tous
Voyez la proposition du classeur joint.
J'ai finalement retenu la formule
Code:
[COLOR="DarkSlateGray"][B]=SOMMEPROD(1*(MOD($A2;B$1^LIGNE($1:$10))=0))[/B][/COLOR]
judicieusement suggérée par job75, formule qui est nettement plus légère que la formule matricielle avec SOMME().

J'y ai mis aussi la formule personnalisée
Code:
[COLOR="DarkSlateGray"][B]Function vp(a&, p&)
Dim i&, q&
   If a Then
      If a \ p Then
         q = p
         Do Until q * (a \ q) - a
            q = p * q
            i = i + 1
         Loop
         vp = i
      End If
   Else
      vp = ""
   End If
End Function[/B][/COLOR]
Vous verrez qu'il est facile de transposer la présentation des tableaux.​
Bonne fin de semaine.
ROGER2327
#3478


26 Floréal An CCXVIII
2010-W19-6T10:07:30Z
 

Pièces jointes

  • Valuation p-adique_3478.zip
    7.7 KB · Affichages: 30
Dernière édition:

job75

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Re,

Si bien sûr vous voulez aussi décaler vers le bas la cellule A2 :

Code:
=SOMME(1*(MOD([COLOR="Red"]DECALER($A2;COLONNES($B1:B1)-1;)[/COLOR];DECALER($EI2;COLONNES($B1:B1)-1;)^LIGNE($A$1:$A$10))=0))

Edit : salut Roger, j'avais proposé SOMMEPROD au post #9, mais c'est bien de résumer la situation :)

A+
 
Dernière édition:

Levis

XLDnaute Nouveau
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Non, la formule ne fonctionne pas... (c'est sûrement moi qui manipule mal)

Ca décale en effet vers le bas mais la formule ne marche plus (exemple : valuation 3-adique de 2 = 1)

Avoir une formule lourde et difficile à calculer ne me dérange pas, mon PC suit pour l'instant.

Je refais.
La formule suivante fonctionne bien :
=SOMME(1*(MOD($A2;$EI1^LIGNE($A$1:$A$10))=0))

J'avais mes nombres premiers de EI1 à IV1
Comme il me faut plus colonnes, je supprime les premiers en colonne et je les mets en ligne de EI1 à EI125, mais la formule fait passer EI1 à EJ1, et il faudrait que ça passe à EI2.
 
Dernière édition:

job75

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Re,

Le dollar, cher Levis, le dollar, il n'y a que ça :

Code:
=SOMME(1*(MOD($A2;DECALER([COLOR="Red"][SIZE="3"]$[/SIZE][/COLOR]EI1;COLONNES($B1:B1)-1;)^LIGNE($A$1:$A$10))=0))

Attention, si vous continuez comme ça, vous allez finir au ZOP :p

Edit : heureusement que j'ai vu votre formule au post #26 avant que vous n'effaciez ;)

A+
 
Dernière édition:

ROGER2327

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Re...
Edit : salut Roger, j'avais proposé SOMMEPROD au post #9, mais c'est bien de résumer la situation :)

A+
... ce qui ne m'avait pas échappé, puisque je disais :
J'ai finalement retenu la formule
Code:
[COLOR="DarkSlateGray"][B]=SOMMEPROD(1*(MOD($A2;B$1^LIGNE($1:$10))=0))[/B][/COLOR]
judicieusement suggérée par job75, formule qui est nettement plus légère que la formule matricielle avec SOMME().
Il faut rendre à César ce qui appartient à César.
ROGER2327
#3479


26 Floréal An CCXVIII
2010-W19-6T12:14:52Z
 

job75

XLDnaute Barbatruc
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Re Roger,

Pas de problème Roger, de toute façon c'est bien secondaire.

Sauf erreur, j'avais envoyé mon message avant d'avoir vu la modification du vôtre.

A+
 

Levis

XLDnaute Nouveau
Re : MATHS & EXCEL : Décomposition d'un nombre ?

Merci ça marche effectivement avec votre dernière formule.
Malheureusement je n'ai toujours pas trouvé ce que je voulais, je commence à être découragé mais j'aimerais faire une dernière tentative.
Il faudrait que je gagne encore en colonnes.

Par exemple pour la ligne correspondant à 1456, j'ai sur chaque colonne la valuation p-adique où p (premier) va de 2 à 1559, et il faut ensuite dans un second temps que je somme toutes ces valuations. Le problème est que toutes les colonnes sont prises, et je voulais savoir s'il était possible de sommer directement toutes les valuations p-adiques de 1456 en 1 seule cellule ?
C'est-à-dire que
FONCTION(1456=2^4 * 7^1 *13^1) = 4+1+1=6 (j'ai ma liste de premiers jusqu'à 1559)
J'imagine que ça doit commencer à faire une fonction complexe...
Merci !
 

Discussions similaires

Statistiques des forums

Discussions
292 810
Messages
1 926 466
Membres
183 092
dernier inscrit
Juvenat