macro pour supprimer les linges qui contiennent #N/A

tapha20

XLDnaute Occasionnel
Bonjour à tous

Je pensais avoir terminé mon projet mais on m'ademandé un travail supplémentaire!!!!!!!!!!

je cherche une macro qui permet de supprimer toutes les lignes qui contiennent dans leur cellules correspondant à la colonne C ce résultat (#N/A) issu d'une recherche v.

exemple: Les lignes 2, 13, 103 et 106,... doivent être supprimées et ne plus apparaitre dans le fichier car dans leur cellules respectives qui correspondent biensur à la colonne C cad (C2; C13; C103; C106,....) contiennent toutes #/NA.

JE vous remercie de votre aide.

Je suis à la bourrrrrrrre.

Crodialement
 

Fichiers joints

francedemo

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

bonjour,
à tester dans ta boucle i
If IsError(Range("C" & i)) Then Rows(i).Delete

ça va supprimer toutes les lignes en erreur

à +
 

Pierrot93

XLDnaute Barbatruc
Re : macro pour supprimer les linges qui contiennent #N/A

Bonjour,

essaye en modifiant comme suit :
Code:
Option Explicit
Sub suplingevde()
Dim i As Long
Application.ScreenUpdating = False
With Sheets("Données")
    For i = .UsedRange.Rows.Count To 1 Step -1
        If Application.CountA(.Rows(i)) = 0 Or .Range("B" & i).Value = "" Or IsError(.Range("C" & i).Value) Then .Rows(i).Delete
    Next i
End With
Application.ScreenUpdating = True
End Sub
bonne journée
@+

Edition : bonjour FranceDemo, un peu en retard moi....
 

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

merci infiniment

ç a bien marché...

Je peux continuer mon fameux projet


Cordialement
 

francedemo

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

bonjour Pierrot
tu sais bien qu'il n'y a ni retard, ni avance sur un forum d'entraide, juste des solutions apportées par chacun...
en plus Excel permet souvent plusieurs approches d'un même pb, ce qui permet plusieurs solutions...
à +
 

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

Re bjr à tous

c pas faux ce que tu dis,

en parlant de solution... voilà mon boss me demande de claculer le pourcentage de D1 réalisé en moins de 30 jours

et le pour centage de D2 réalisé en moins de 30 jours aussi.

Sur le noveau doc (avec correction de ta macro) est ce que tu peux me suggerer quelques idées pour cela.

en gros: je cherche le nombre d'affaire réalisées en D1 qui n'ont pas dépassé les 30 jours

et en suite le nombre d'affaire réalisées en D2 qui n'ont pas dépassé aussi 30 jours.

en résumé: D1-D0 < à 30 jours.

et D2-D1 < à 30 jours.

Cordialement
 

Fichiers joints

Legolas

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

Bonjour,

Dans la colonne G, à la place de OK mettre 1 et à la place de KO mettre 0

Soit la formule à appliquer sur toute la colonne :
Code:
=SI(D2="";"";SI(E2="";"";SI(E2-D2<30;1;0)))
Et dans une cellule vide mettre la formule (au format pourcentage) :
Code:
=SOMME(G2:G1089)/NB(G2:G1089)
Idem pour l'autre calcul.

A plus
 
Dernière édition:

francedemo

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

alors,
en H2, je mets => =SI(D2="";"";SI(E2-$D2<31;1;0))
en I2, je mets => =SI(E2="";"";SI(F2-$D2<31;1;0))
à tirer jusqu'en bas
en H1, je mets => =SOMME(H2:H21)/NB(H2:H21)
en I1, je mets=> =SOMME(I2:I21)/NB(I2:I21)
remplacer "21" par la valeur de la fin de ton tableau

tout ça à adapter à tes besoins...

à+

edit: comme quoi...
 

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

j'essaye ça, et jete tiens au courant


si non il n' a pas un autre moyen pour prendre en compte les cellules non vides. (exempel celulles 21)

car il faut regarder les résultat chaque semaine et et il y a des lignes qui se rajouttent, ou pas....

merci bien
 

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

j'ai essayé ce que vous m'avez montré

logiquement ça a marché par contre ce n'était pas mon objecitf.

j'ai du mal expliqué, ..ce que vous m'avez fait est le resultat total, moi je cherche les resultats par semaine.

donc je pense qu'il faut rajouter une colonne semaine avec cette formule no.semaine (date)-1.

et il faut prendre en compte cette condition dans la formule de calcul final.

J'essaye tjrs.

cordialement.
 

francedemo

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

alors :
en G1, tu mets le n° de semaine qui t'interresse
en H2 => =NO.SEMAINE(D2)
en I1 => =SOMME(I2:I21)/NB(I2:I21)
en I2 => =SI(H2=G1;SI(D2="";"";SI(E2-$D2<31;1;0));0)
en J1 => =SOMME(J2:J21)/NB(J2:J21)
en J2 => =SI(H2=G1;SI(E2="";"";SI(F2-$D2<31;1;0));0)
à adapter...
à+
 

francedemo

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

en fait, en G1 tu indiques la semaine que tu veux surveiller
tu colles les formules indiquées dans les cellules correspondantes et en I1 et J1, tu as tes %

si tu veux une vue globale avec toutes les semaines, c'est une autre chose...
 

Legolas

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

Re,

En G2 => =NO.SEMAINE(D2) (à étirer sur toute la colonne)
En H2 => =SI(D2="";"";SI(E2="";"";SI(E2-D2<30;1;0))) (à étirer sur toute la colonne)
En I2 => =SI(E2="";"";SI(F2="";"";SI(F2-E2<30;1;0))) (à étirer sur toute la colonne)

En K2 => =SOMME.SI.ENS($H$2:$H$xx;$G$2:$G$xx;G2)/NB($H$2:$H$xx) (à étirer sur toute la colonne, en remplaçant xx par la dernière ligne de donnée)
Ca te donne le pourcentage pour chaque semaine.

A adapter pour les données de la colonne I

A plus
 

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

justement c'est ça ce que je cherche

voilà en gros le travail final

ile me manque jsute à trouver les formule dans le tableau final

cordialement
 

Fichiers joints

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

explication formules

J2: si le résultat est de 1, cela veut dire qu'il y a D1 et qu'elle est réalisée dans le délai de 30 jours max.
J2: si le résultat est de 0 celau veut dire qu'il y a eu D1 mais qu'elle n'a pas été réalisée dans les 30 jours max.
J: si s'il y a un vide cela veut dire qu'il n y a pas eu de D1.

Cordialement
 

Legolas

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

Quelle est la différence entre qualification, PDR à réaliser et PDR réalisés ?
J'imagine que c'est une condition supplémentaire pour les calculs... mais je ne trouve pas cette information en Feuil2.
 

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

Qualifiaction c la D1
PDR à réalisé c'est une D1 mais qui n'est pas encore de venue D2

PDR réalisée c'est une D2.
 

tapha20

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

se sont des dates.

exemple: numér od'affaire D323/066216; c'esst un devis COLL, la date de premier contact c'est DO, (12/01/2012), il a été qualifié donc D1 (21/01/2012) même jour. et le devis a été réalisé donc D2 PDR réalisé (02/02/2012) le délai de réalisatio net d'environ 30 jourss.
 

Legolas

XLDnaute Occasionnel
Re : macro pour supprimer les linges qui contiennent #N/A

Re,

Je ne sais pas si j'ai tout bien saisi.
Voici une proposition en pièce jointe.

Est-ce ce qui est attendu ?

A plus
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas