Microsoft 365 Macro pour supprimer des cellules sauf conditions

RAHFOU

XLDnaute Nouveau
Bonjour à tous,



J'ai seulement quelques notions en VBA alors je sollicite votre aide pour une requête :)

J'ai dans la colonne A(Feuille1) des adresses mails, dans la colonne B(Feuille2) celles que je veux supprimer (ce qu'il y a après le @) et dans la colonne C(Feuille2) les e-mails à ne pas supprimer (SAUF ceux là).

J'aimerais construire une macro qui traduirait ceci : "Si tu trouves dans la colonne A(Feuille1) un des champs de la colonne B(Feuille2) sauf les conditions de la colonne C(Feuille2), alors tu supprimes"

J'ai essayer via une formule sur un exemple mais je ne trouve pas un moyen de supprimer et de rajouter le "sauf si"
=SI(DROITE(A1;NBCAR(A1)-TROUVE("@";A1))="###.com";"SUPP";"")

A mon avis, c'est une macro qu'il faut pour ce cas.



Je ne sais pas si j'ai été claire, n'hésitez pas à me poser des questions si nécessaire.


Je vous remercie !

A bientôt !
 

Discussions similaires

Haut Bas