Macro compléter une partie de texte

milo2013

XLDnaute Nouveau
Bonjour a tous!

Je fais appel à vous car je n'arrive pas effectuer une macro sur excel.
J'ai un fichier avec environ 1000 désignations qui ne sont pas complètes et je voudrais les compléter avec les valeurs des cellules adjacentes. Seul problème un concaténer ne peux pas marcher car mon texte peut s'insérer variablement dans la suite de caractères.
(ex. CONDO FILM POLYPROPYLENE 1UF 5% ; 450V => CONDO FILM POLYPROPYLENE 1UF 450V 5%). J'ai déjà fouillé le net et exceldownloads mais sans grand succès.
J'ai joint une partie de mon exemple dans un fichier.

Merci d'avance pour vos réponses.
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Re : Macro compléter une partie de texte

Bonjour le fil,

Une autre tentative formule, basée sur les points suivants :

- Le voltage doit suivre les codes UF, PF ou NF
- Pour éviter toute confusion avec un nom qui contiendrait ces lettres, le code doit être précédé d'un chiffre

Ca donne ceci :

Code:
=SI(ESTNUM(STXT(B3;SI(NB.SI(B3;"*PF*");TROUVE("PF";B3);0)+SI(NB.SI(B3;"*UF*");TROUVE("UF";B3);0)+SI(NB.SI(B3;"*NF*");TROUVE("NF";B3);0)-1;1)*1);GAUCHE(B3;SI(NB.SI(B3;"*PF*");TROUVE("PF";B3);0)+SI(NB.SI(B3;"*UF*");TROUVE("UF";B3);0)+SI(NB.SI(B3;"*NF*");TROUVE("NF";B3);0)+2)&C3&STXT(B3;SI(NB.SI(B3;"*PF*");TROUVE("PF";B3);0)+SI(NB.SI(B3;"*UF*");TROUVE("UF";B3);0)+SI(NB.SI(B3;"*NF*");TROUVE("NF";B3);0)+2;50);"")
@+
 

milo2013

XLDnaute Nouveau
Re : Macro compléter une partie de texte

Merci beaucoup.
C'est exactement ce qu'il me fallait. je pensais faire par macro mais une formule c'est parfait.
Merci à tous.
A bientôt.
 

Discussions similaires


Haut Bas