[Macro] Comparer deux colonnes et copier données

Elrian

XLDnaute Nouveau
Bonjour,

Etant débutant en Visual Basic j'aurais besoin de votre aide pour élaborer une macro.

Je travaille sur un classeur contenant quatres colonnes:

Sur Feuil1 A et B contenant du texte

Sur Feuil2 C contenant du texte et D vide

J'aimerai comparer les colonnes A et C et si le contenu est le même copier B dans D.

Merci de votre aide
 

Fichiers joints

Dranreb

XLDnaute Barbatruc
Re : [Macro] Comparer deux colonnes et copier données

Bonjour.
Si vous tenez à faire une macro pour ça, faites la mettre en place des formules appropriées suivantes puis figer les valeurs qu'elles rendent.
En colonne E (j'espère que ça ne vous dérange pas de l'utiliser, sinon on pourra la repousser plus à droite):
Code:
=EQUIV(Feuil2!$C:$C;Feuil1!$A:$A;0)
En colonne D:
Code:
=SI(ESTNA($E2);"";INDEX(Feuil1!$B:$B;$E2))
Cordialement.
 

Elrian

XLDnaute Nouveau
Re : [Macro] Comparer deux colonnes et copier données

Les formules marchent bien je vous remercie!

Je vais essayer de les retranscrire en VBA et reviendrai vers vous si problème.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas