XL 2013 Ligne qui se copie automatiquement sur une autre feuille

Louisette

XLDnaute Nouveau
Bonjour à tous,

Débutante en Excel, j'aimerais faire une manip assez simple sans VBA si possible.

J'ai sur une 1ère feuille un tableau qui comporte des données en colonne A, B, C, D etc.
Je voudrais que si un mot spécifique (disons "voiture") apparaisse en colonne C, alors l'ensemble de la ligne se copie sur ma 2ème feuille.
Il faudrait que les données s'incrémentent les unes à la suite des autres sur la 2ème feuille, sachant que la première feuille comprend de nouvelles données chaque jour.

Je vous remercie pour votre aide et vous souhaite une bonne journée!
 

Rouge

XLDnaute Impliqué
Bonjour

Formule matricielle en A2 de la feuille "Feuil2" à valider avec CTRL + SHIFT + ENTREE puis à tirer vers la droite et vers le bas.

=SIERREUR(INDEX(Feuil1!$A$1:$G$1000; PETITE.VALEUR(SI(Feuil1!$C$2:$C$1000="voiture";LIGNE(INDIRECT("1:"&LIGNES(Feuil1!A2:A1000))));LIGNES($1:1))+1;COLONNE());"")

en validant avec les touches combinées "CTRL + SHIFT + ENTREE", cela encadre automatiquement la formule avec des accolades.

Fichier en exemple joint.

Cdlt
 

Pièces jointes

  • Louisette_Ligne qui se copie automatiquement sur une autre feuille.xlsm
    10.8 KB · Affichages: 17

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
291 805
Messages
1 918 120
Membres
179 933
dernier inscrit
louys
Haut Bas