XL 2010 Je suis Scié

tuti

XLDnaute Occasionnel
bonjour,
je me permets de vous demander un petit cours sur la fonction SI(ET

comment dois je formuler le contenu du ET pour que le calcul se fasse si le contenu de la celule est "Non vide" ?

Exemple de calcul :
A1 + A2 = A3

comment formulé la condition ET pour qu'il me fasse le calcul si ET A1 ET A2 soit rempli ?

la formule doit ressemble à quelque chose comme cela
=SI(ET(A2;A3);A2+A3;"")

mais je veux vérifier que A2 et A3 contiennent bien des chiffres

merci
 

tuti

XLDnaute Occasionnel
merci
2 versions pour une même question


=SI(ET(E3="";F3="");"";F3-E3)
ou
=SI(ESTNUM(E2:F2);F2-E2;"")

@piga25
avec ta formule, il fallait que je tombe dans le piège
j'y ai mis les 2 pieds
j'ai écris ETNUM au lieu de ESTNUM


cela est bon dans la plupart du temps, mais pas dans mon cas
car il s'agit de soustraire des Heures ( et donc pas des nombres )
il renvoie une valeur nulle dans mon cas
il m'aurais fallu le calcul ESTHOR ou ESTTIME


je vous remercie,
je fais rester sur la version de @JM27
 

eriiic

XLDnaute Barbatruc
Bonjour,

Et c'est en sciant que Léonard De Vinci...
cela est bon dans la plupart du temps, mais pas dans mon cas
car il s'agit de soustraire des Heures ( et donc pas des nombres )
Soustraire ? Pourquoi faire une addition alors ? Tu parles de A1:A2 et ensuite tu additionnes A2:A3.
Tu ne pourrais pas faire un peu le tri dans ta tête, te relire et rester cohérent, ça ferait plus sérieux ;-)

Les heures et les dates sont des nombres.
Si ce n'est pas le cas c'est qu'ils sont mal saisis et sont en texte. Saisir 13:50
Et la cellule avec la formule doit être au format horaire adéquat. hh:mm ou [h]:mm si heures >24

Sinon une énième variante :
Code:
=SI(NB(A2:A3)=2;A2+A3;"")
eric
 

Discussions similaires

Statistiques des forums

Discussions
291 805
Messages
1 918 120
Membres
179 933
dernier inscrit
louys
Haut Bas