Interdire une double saisie dans une plage de cellules dans Excel.

cogestia

XLDnaute Nouveau
Bonjour ;
Après recherche, je n’ai pas trouvé une réponse à mon interrogation, peut-être pouvez vous m’aider ?
Dans la plage de cellule A9 à A 18, je voudrais interdire la saisie d’un date identique.
Par exemple, en A4, je saisis le 12/12/2013, ors cette date a déjà été saisie en A3.
Comment interdire la saisie de ce doublon ?
Et la cerise sur le gâteau, comment faire apparaître, lors de la saisie de ce doublon, un message du type « La date que vous venez de saisir est déjà utilisée, choisissez une nouvelle date. »
Je dois vous préciser que je ne sais pas utiliser VBA, d’ailleurs, je ne sais même pas comment y accéder.
Merci de votre aide.
 

Robert

XLDnaute Barbatruc
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Bonjour Cogestia, bonjour le forum,

En pièce jointe un petit exemple avec la macro événementielle Change ci-dessous :
Code:
Private Sub Worksheet_Change(ByVal Target As Range)
Dim pl As Range 'déclare la variable pl (PLage)

Set pl = Range("A9:A18") 'définit la plage pl
If Application.Intersect(pl, Target) Is Nothing Then Exit Sub 'si le changement a lieu ailleurs que dans la plage pl, sort de la procédure
If Target.Value = "" Then Exit Sub 'si le cellule est effacée, sort de la procédure
If Application.WorksheetFunction.CountIf(pl, Target) > 1 Then 'condition : si le nombre d'occurrence de la cellule éditée est supérieur à 1
    MsgBox "Date déjà utilisée ! Choisissez une nouvelle date." 'message
    Target.ClearContents 'efface le contenu de la cellule éditée
    Target.Select 'sélectionne la cellule éditée
End If 'fin de la condition
End Sub
Le fichier :
 

Fichiers joints

tototiti2008

XLDnaute Barbatruc
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Bonjour cogestia, Bonjour Robert :),

un essai avec Données - Validation sans macro
 

Fichiers joints

JHA

XLDnaute Barbatruc
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Bonjour à tous,

par formule en validation de données

Code:
=NB.SI($A$1:$A1;$A1)<=1
JHA
 

Fichiers joints

Modeste geedee

XLDnaute Barbatruc
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Bonsour®
Bonjour ;
Après recherche, je n’ai pas trouvé une réponse à mon interrogation, peut-être pouvez vous m’aider ?
Dans la plage de cellule A9 à A 18, je voudrais interdire la saisie d’un date identique.
Par exemple, en A4, je saisis le 12/12/2013, ors cette date a déjà été saisie en A3.
Comment interdire la saisie de ce doublon ?
Et la cerise sur le gâteau, comment faire apparaître, lors de la saisie de ce doublon, un message du type « La date que vous venez de saisir est déjà utilisée, choisissez une nouvelle date. »
Je dois vous préciser que je ne sais pas utiliser VBA, d’ailleurs, je ne sais même pas comment y accéder.
Merci de votre aide.
utiliser un validation de données :
Capture0.JPGCapture1.JPG
Capture2.JPGCapture3.JPG
 

Fichiers joints

cogestia

XLDnaute Nouveau
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Sauf si je n'ai pas compris la réponse, ce type d'action ne gère qu'un message d'information de format de saisie.

Je vous rapelle que je cherche à interdire la saisie d'un doublon d'une cellule dans une plage de cellules.
 

tototiti2008

XLDnaute Barbatruc
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Re,
Bonjour JHA :), Bonjour Modeste GD :),

Tu as essayé nos fichiers respectifs ou d'appliquer la méthode décrite par Modeste GD ?
Que se passe-t-il si tu tapes 2 fois la même date ?
 

cogestia

XLDnaute Nouveau
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Milles excusent, ma réponse est un peu hâtive.
J’ai effectué la procédure comme indiquée dans la 1ère cellule concernée (A8).
Mais lorsque je saisis une date en A8, quelle que soit la date, le message d’arrêt se déclenche alors qu’aucune date identique n’est utilisée.
Une autre solution ou une modification à apporter ??
 

Robert

XLDnaute Barbatruc
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Bonjour le fil, bonjour le forum,

As-tu essayé la proposition VBA que je t'ai faite en post #2 ? Même si la solution par validation de données me paraît bien plus efficace, mais si ça plante, tu pourrais essayer par VBA...
 

cogestia

XLDnaute Nouveau
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Bonjour à tous,

par formule en validation de données

Code:
=NB.SI($A$1:$A1;$A1)<=1
JHA
Merçi JHA, c'est super cela fonctionne parfaitement.

Merçi à tous ceux qui on fait une réponse.
 

phlaurent55

XLDnaute Barbatruc
Re : Interdire une double saisie dans une plage de cellules dans Excel.

Bonjour à tous,
Milles excusent, ma réponse est un peu hâtive.
J’ai effectué la procédure comme indiquée dans la 1ère cellule concernée (A8).
Mais lorsque je saisis une date en A8, quelle que soit la date, le message d’arrêt se déclenche alors qu’aucune date identique n’est utilisée.
Une autre solution ou une modification à apporter ??
la question initiale était:
Après recherche, je n’ai pas trouvé une réponse à mon interrogation, peut-être pouvez vous m’aider ?
Dans la plage de cellule A9 à A 18, je voudrais interdire la saisie d’un date identique.
Par exemple, en A4, je saisis le 12/12/2013, ors cette date a déjà été saisie en A3.
Comment interdire la saisie de ce doublon ?
et les solutions de Robert et tototiti sont correctes et fonctionnent à condition de saisir une date "Dans la plage de cellule A9 à A 18" et pas en A8, A3 ou A4

à+
Philippe
 

Discussions similaires


Haut Bas