XL 2016 insertion de préfixe devant numéro de téléphone

dmkane03

XLDnaute Nouveau
Bonjour à tous,
dans un souci de mieux disposer des contact de tous les clients, j'essaye d'associer a chaque nom un numéro.
cela avait déjà été fait cependant, la nouvelle numérotation en vigueur dans notre pays me rend la tache difficile
J'aimerai avoir une solution avec une formule Excel pour pouvoir insérer le préfixe devant les numéro téléphoniques existants par opérateur.
Merci d'avance
 

job75

XLDnaute Barbatruc
Bonjour dmkane03

Si les numéros de téléphone sont des nombres en colonne A et que le préfixe est 33 entrez en B2 :
Code:
=--(33&A2)
Edit : salut JHA.

A+
 
Dernière édition:

dmkane03

XLDnaute Nouveau
Nous avons 3 operateurs mobile en CI, a savoir MOOV,MTN,ORANGE
Le préfixe pour MOOV est 01
Le préfixe pour MTN est 05
Le préfixe pour orange est 07
Les numeros MOOV ont pour debut 01,02,03,41,42,43,51,52,53,61,62,63,71,72,73,81,82,83
les numeros MTN ont pour debut 04,05,06,44,45,46,54,55,56,64,65,66,74,75,76,84,85,86
les numeros ORANGE ont pour debut 07,08,09,47,48,49,57,58,59,67,68,69,77,78,79,87,88,89
un exemple : 45-79-37-13 est un numero MTN, je voudrais une formule qui me permette d'inserer le préfixe pour MTN cest à dire le 05 devant tout les numeros en tenant en compte les numero de debut pour MTN et ainsi de suite pour les autres opérateurs
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Si tes données sont en format texte
VB:
=SI(ESTNUM(EQUIV(GAUCHE($C17;2);MOOV;0));"MOOV "&C17;SI(ESTNUM(EQUIV(GAUCHE($C17;2);MTN;0));"MTN "&$C17;SI(ESTNUM(EQUIV(GAUCHE($C17;2);ORANGE;0));"ORANGE "&$C17)))

JHA
 

Pièces jointes

  • Classeur Tel DMKANE03.xlsx
    11.6 KB · Affichages: 3

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
288 632
Messages
1 893 633
Membres
169 984
dernier inscrit
mdemrs
Haut Bas