1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Incrémenter les doublons sans VBA

Discussion dans 'Forum Excel' démarrée par Richardb01, 12 Août 2017.

  1. Richardb01

    Richardb01 XLDnaute Nouveau

    Inscrit depuis le :
    12 Août 2017
    Messages :
    5
    "J'aime" reçus :
    0
    Bonjour,
    après plusieurs recherche je ne trouve pas la solution à mon problème. Pour faire simple régulièrement environ 2 fois par mois j'envoie des emailings à mes clients et je fais le suivi sur excel (cf. pj).

    mon classeur se compose d'une feuille principale "clients" et d'un nombre indéfini de feuilles pour les emailings (1 par emailing).
    Dans la feuille "client" j'ai les colonnes "emails" , "date" , "ouverts" , "clics" , "désabonnement".

    Mise en situation :
    J'ai fais un nouvel emailing "news02" je crée ma feuille et colle dans chaque colonne les statistiques de la news (les ouverts, clics et désabonnements).

    Est-il possible avec une formule d'incrémenter de +1 les doublons dans la feuille "clients" ?

    Aussi ce serait un plus mais je doute que ce soit possible sans VBA de mettre la dernière de mise à jour dans "date" dans la feuille "clients" ? ceci me permet d'éviter de renvoyer l'actualité à une personne la semaine suivante si elle l'a déjà ouvert.

    Je ne sais pas si tout est très clair, merci d'avance pour votre aide cela me ferait gagner de nombreuses heures de ctrl+c / ctrl+v :)
     

    Pièces jointes:

  2. eriiiic

    eriiiic XLDnaute Accro

    Inscrit depuis le :
    12 Juillet 2008
    Messages :
    1758
    "J'aime" reçus :
    80
    Utilise:
    Excel 2010 (PC)
    Bonjour,

    Doublons ? Quels doublons ? A part les dates je n'en vois pas...
    eric
     
  3. Richardb01

    Richardb01 XLDnaute Nouveau

    Inscrit depuis le :
    12 Août 2017
    Messages :
    5
    "J'aime" reçus :
    0
    Bonjour Eric,

    En effet ce n'est pas très clair.. je veux que lorsque sur une nouvelle feuille "news.." se trouve un email déjà présent dans "clients" ce que j'appelle "doublons" je souhaite incrémenter +1.
    Exemple si dans mon prochain emailing j'ai email01@email.fr qui a ouvert et cliqué, alors dans ma feuille "client" on incrément de +1 en colonne B et C de la ligne correspondante.
    Espérant avoir répondu à ta question
    Merci
     
  4. eriiiic

    eriiiic XLDnaute Accro

    Inscrit depuis le :
    12 Juillet 2008
    Messages :
    1758
    "J'aime" reçus :
    80
    Utilise:
    Excel 2010 (PC)
    Bonjour,

    Sur chaque feuille news une date de traitement est mise en D1. La laisser sinon la feuille sera compter une 2nde fois.
    Ou, si tu ne désires pas garder l'historique des feuille news, tu peux travailler avec une seule où tu colles ton extraction. Dans ce cas mettre en commentaire la ligne sh.[D1] = Date pour que la date ne soit pas mise et que la feuille news soit traitée à chaque fois.
    A tester...
    eric
     

    Pièces jointes:

  5. Richardb01

    Richardb01 XLDnaute Nouveau

    Inscrit depuis le :
    12 Août 2017
    Messages :
    5
    "J'aime" reçus :
    0
    Bonjour Eric,
    merci beaucoup d'avoir pris le temps de te pencher sur ma demande!
    J'ai bien regardé sur ton fichier le soucis est que lorsque je vais ajouter une nouvelle feuille de statistique d'une news elle n'est pas pris en compte, sinon ça me semble parfait! :)
    J'ai bien essayé de regarder le code VBA mais je n'y connais rien du tout :-/

    En attendant ta réponse j'avais trouvé une autre solution sur la toile mais en formule, je post le fichier si ça peut aider d'autres personnes. Le soucis sur ce nouveau fichier est que si j'ajoute une feuille je rencontre le même problème (sauf que côté date je n'ai pas regardé)

    Si j'anticipe le nombre de news admettons 1000 pour être tranquille et que je mets :
    =SOMMEPROD(NB.SI(INDIRECT("'news"&LIGNE($1:$1000)&"'!A2:A60");$A2))

    au lieu de

    =SOMMEPROD(NB.SI(INDIRECT("'news"&LIGNE($1:$2)&"'!A2:A60");$A2))

    comme sur le fichier exemple il y a 2 news, alors je me retrouve avec l'erreur #REF. Donc cela implique de mettre à jour les formules des 3 colonnes dans la feuille "client" à chaque nouvel ajout de news.

    Merci pour votre aide que ce soit côté VBA ou formule, si vous avez une idée je suis preneur :)

    Bonne journée
     

    Pièces jointes:

  6. eriiiic

    eriiiic XLDnaute Accro

    Inscrit depuis le :
    12 Juillet 2008
    Messages :
    1758
    "J'aime" reçus :
    80
    Utilise:
    Excel 2010 (PC)
    Bonjour,

    pour qu'elle soit prise en compte le nom d'une feuille doit commencer par "news".
    Si pb déposer le fichier au lieu de dire ça ne marche pas qui n'apporte rien.
    eric
     
  7. Richardb01

    Richardb01 XLDnaute Nouveau

    Inscrit depuis le :
    12 Août 2017
    Messages :
    5
    "J'aime" reçus :
    0
    Et bien écoute c'est ce que j'ai fait.. et je ne pense pas m'être montré offensant?
    Cordialement
     
  8. eriiiic

    eriiiic XLDnaute Accro

    Inscrit depuis le :
    12 Juillet 2008
    Messages :
    1758
    "J'aime" reçus :
    80
    Utilise:
    Excel 2010 (PC)
    Non.
    Je te parlais pour la macro...
    Tu as déposé un fichier avec les formules, sans macro et sans cette fameuse nouvelle feuille non prise en compte. Comment veux-tu que je vois le pourquoi ?
     
  9. Richardb01

    Richardb01 XLDnaute Nouveau

    Inscrit depuis le :
    12 Août 2017
    Messages :
    5
    "J'aime" reçus :
    0
    Ah ok au temps pour moi. En effet je n'ai mis que la solution sans macro du coup c'est chose faite.
    Par contre peut-être cela peut venir d'un soucis de compatibilité? ma version est 2013.
    J'ai donc ajouté une feuille "news03" en recopiant le contenu de la feuille "news01" avec seulement la date qui change.
    Merci
     

    Pièces jointes:

  10. eriiiic

    eriiiic XLDnaute Accro

    Inscrit depuis le :
    12 Juillet 2008
    Messages :
    1758
    "J'aime" reçus :
    80
    Utilise:
    Excel 2010 (PC)
    Tu as mal compris les explications.
    C'est la macro qui met la date de prise en compte pour ne pas la traiter la feuille 2 fois. Donc supprime cette date et la macro traitera cette feuille.
     

Partager cette page