Imbriquer + 7 Si

M

Moa

Guest
Bonsoir à tous !

Voilà, j'ai une formule ou je dois imbriqué plus de 7 "SI", et naturellement, faut trouver une technique.

Je suis allé sur le forum, sachant que le sujet a déjà été traité, mais malgré l'exemple de Monique, je n'y arrive pas.

Aussi voilà, ce que je dois dire :

Si CL11=1 alors recopie C16
CL11=2 aors recopie D16
CL11=3 alors recopie E16

Et ainsi de suite jusqu'à 13 possibilités.

J'ai donc écrit =Si($CL$11=1;C16;Si($cL$11=2;D16;Si bla bla bla...)

et naturellement arrivé à CL11=9...plus moyen.

Sahant qu'après j'étire cette formule sur 1000 lignes.

Voilà, si qqn à une idée, car je sèche.

En fait j'ai trouvé une solution, qui est de faire de 1 à 8, dans une colonne, puis de 6 à 13 dans une autre colonne, puis de 1 à 4 + 9 à 13, dans une autre colonne.

Mais le problème, c'est que ces résultats devant servir à d'autres comparaisons etc...je multiplie tout le travail par 3.

Merci beaucoup d'avance.

@ +

Moa
 
J

Jean-Marie

Guest
Bonjour Moa,

Je n'ai pas vu ce que t'as proposé Monique...

La fonction décaler est à utiliser pour ton problème.

dans la première cellule de ton tableau tu tapes cette formule
=decaler(B16;0;C$L$11)

et tu fais une recopie incrémentée.

Bonne journée.

@+Jean-Marie
 
A

andré

Guest
Salut Moa,

Pourquoi n'essaies-tu pas de résoudre ton problème par la fonction RECHERCHEH en créant une ligne supplémentaire ?
Si tu ne vois pas ce que je veux dire, fais-moi signe et je te poste un exemple.

André.
 
A

andré

Guest
Resalut Moa,

Je n'ai pas attendu ta réponse.
Vois l'exemple joint et dis-moi si cela répond à ta question.

André
 

Fichiers joints

M

Moa

Guest
Salut André et jean-Marie.

En fait j'ai cherché toute la nuit, puis j'ai opté pour plein de colonnes intermédiaires.

Puis en venant ce matin, sur le forum, j'ai éssayé la formule de Jean-Marie, et j'ai tout refait.

Ta formule, JM, marche super bien dans mon exemple.

André, je viens seulement de voir ton message.La rechercheH, je l'avais déjà éssayé , mais dans ce cas, elle n'allait pas.

Je ne peux pas télécharger ton fichier, mais dès que je le pourrai, je le ferai et le regarderai avec beaucoup d'attention.

Bonne journée

@ +

Moa
 
M

Moa

Guest
Astuce trouvée, cette nuit, sur le site :


<http://disciplus.simplex.free.fr/>




Imbriquer plus de 7 si


Existe t-il un moyen, tout en restant dans la même cellule de dépasser
le nombre de 7 SI qui s'imbriquent dans une fonction ?



Nommer la formule qui a une serie de 7 si (sept1)
dans une cellule:
=SI($A$1=1;11;SI($A$1=2;22;SI($A$1=3;33;SI($A$1=4;44;SI($A$1=5;55;SI($A$1=6;
66;SI($A$1=7;77;FAUX)))))))

nommer la formule qui a une autre serie de 7 si (sept2)
dans un autre cellule:
=SI($A$1=8;88;SI($A$1=9;99;SI($A$1=10;100;SI($A$1=11;110;SI($A$1=12;120;SI($
A$1=13;130;SI($A$1=14;140;FAUX)))))))

dans une troisième:
=si(sept1;sept1;sept2)

... Pat
 
@

@lex

Guest
Tient voilà la fonction index et comment l'utiliser

Ce sera la solution la plus concrète si tu as plus de mille lignes (ou colonnes)

à+

@lex
 

Fichiers joints

Discussions similaires


Haut Bas