XL 2010 Ignorer les cellules vides et reconnaissance des cellules pleines

FireSand

XLDnaute Nouveau
Bonjour à tous,

Je me permets de créer ce sujet car je n'ai pas trouvé de réponses ni sur le forum, si sur Internet.

Je suis en train de faire un document Excel où la numérotation s'affiche automatiquement en fonction du contenu auquel il est lié. Selon ce schéma :

-> Si CELLULE_A affiche TERME Et CELLULE_B est différente de VIDE alors CELLULE_C+1

Ce qui fonctionne à priori, puisque à chaque fois que ce terme est affiché, la case numéroté apparait avec +1 (1,2,3,4,5,...etc).

Seulement voilà, mon problème arrive ici. Si plusieurs lignes d'affilées n'affiche pas ce terme, ma formule ne fonctionne plus du tout.

Mon idée, ce serait que la formule ignore les lignes d'en dessus qui sont vides et ajoute un +1 à la première cellule pleine qu'il voit au dessus.

Pour que ce soit plus claire, je vous ai mis un excel en fichier joint.

Un GRAND merci à ceux qui sauront résoudre mon problème. :)
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Bonjour et Bienvenue sur XLD,
merci de mettre les résultats escomptés sur un tableau d'une dizaine de lignes pour que l'on puisse bien saisir ta demande.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Ci joint un exemple avec la fonction max()
=SI(B2="Contenu";MAX($A$1:$A1)+1;"")

JHA
 

Fichiers joints

FireSand

XLDnaute Nouveau
Bonjour R@chid, je vous remercie pour votre accueil.

J'ai fais en sorte d'être plus claire dans le fichier Excel en rajoutant des lignes, selon vos conseils, et un tableau "résultat souhaîté".

En espérant que cela puisse être plus claire. :)
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re,
Salut JHA,

en A2 :
Code:
=SI(B2="";"";NB.SI(B$2:B2;B2))
@ tirer vers le bas

@ + +
 

JHA

XLDnaute Barbatruc
Bonjour à tous,
Salut R@chid,

Un peu tard mais bon comme c'est fait, une autre possibilité

JHA
 

Fichiers joints

FireSand

XLDnaute Nouveau
Bonjour à tous,

J'aurais une sous-question. Cette formule fonctionne parfaitement, et je pense l'utiliser comme cela. Cependant, elle laisse des lignes ne vides. Est-ce qu'il y a un moyen que toutes les données se suivent, en ignorant simplement (sans laisser de lignes vides) les données exclues ?

Un grand merci à ceux qui répondront.
 

Discussions similaires


Haut Bas