ignorer cellules vides

mumuss

XLDnaute Nouveau
Bonjour le forum,
Je me trouve face à un problème. Je ne sais pas trop comment m'expliquer donc j'ai joint un fichier pour que ce soit plus clair, j'espère que quelqu'un pourra m'aider.
Merci d'avance
Pierre
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Re : ignorer cellules vides

Bonjour,

en I8, essaye cette formule :

Code:
=SOMME.SI($C$7:$H$7;"théorie";C8:H8)/SOMME.SI($C$7:$H$7;"pratique";C8:H8)
@+
 

ROGER2327

XLDnaute Barbatruc
Re : ignorer cellules vides

Bonjour mumuss
Essayez ceci en I8 :
Code:
[COLOR="DarkSlateGray"][B]=SOMME(SI($C8:$H8<>"";($C$7:$H$7="théorie")*$C8:$H8))/SOMME(SI($C8:$H8<>"";($C$7:$H$7="pratique")*$C8:$H8))[/B][/COLOR]
À valider par Ctrl + Maj + Entrée.​
ROGER2327
#3698


Lundi 2 Gidouille 137 (Saint Lucullus, amateur (Bloosday), SQ)
28 Prairial An CCXVIII
2010-W24-3T16:32:51Z
 

mumuss

XLDnaute Nouveau
Re : ignorer cellules vides

Bonjour,

en I8, essaye cette formule :

Code:
=SOMME.SI($C$7:$H$7;"théorie";C8:H8)/SOMME.SI($C$7:$H$7;"pratique";C8:H8)
@+
Merci, ça marche bien mais il y a juste un petit problème, c'est que si toute la ligne est vide, ça met "div#0". Comment je pourrais éviter ça?
Merci beaucoup
 

Tibo

XLDnaute Barbatruc
Re : ignorer cellules vides

re,

Dans ce cas, on peut commencer la formule par :

Code:
 =SI(NBVAL(C8:H8)=0;"";la_formule_proposée_plus_haut)
@+
 

mumuss

XLDnaute Nouveau
Re : ignorer cellules vides

Merci beaucoup ça marche très bien. Par contre Pierre Jean, j'ai essayé votre formule et elle m'indique le même résultat pour toutes les cellules, à savoir 0.75. Merci quand même, une petite question, que veut dire barbatruc?:confused:
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas