Ignorer cellules vides dans calcul de moyenne avec coefficients

polog57

XLDnaute Nouveau
Bonjour,
J'essaie d'établir un fichier qui me permettrait de calculer une moyenne sur plusieurs tests avec possibilité de coefficients différents selon les tests.
Mon problème est que certaines cellules sont vides et cela me ramène à des moyennes incohérentes.
Je suppose que même si les cellules aux lignes 3 et 4 sont vides, Excel divise quand même par le total des coefficients de la ligne 2.
Voici ma formule:
=((B3*B2)+(C3*C2)+(D3*D2)+(E3*E2)+(F3*F2)+(G3*G2)+(I3*I2)+(J3*J2)+(K3*K2))/(B2+C2+D2+E2+F2+G2+H2+I2+J2+K2)
Je suppose qu'il y a une autre formule mais je ne la connais pas.
Merci de votre aide.
Cordialement
Paul
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Bonjour,
en L3 :
VB:
=SI(NB(B3:K3);MOYENNE(SI(B3:K3<>"";B3:K3*B$2:K$2));"")
@ valider par Ctrl+Shift+Enter
@ tirer vers le bas


@ + +
 

R@chid

XLDnaute Barbatruc
Re,
je n'ai pas encore compris, tu veux la somme des produits des notes * les coefficients devisier par la somme des coefficients apparemment non ?
 

R@chid

XLDnaute Barbatruc
Re,
Re,
je n'ai pas encore compris, tu veux la somme des produits des notes * les coefficients devisier par la somme des coefficients apparemment non ?
dans ce cas :
VB:
=SIERREUR(SOMMEPROD(B3:K3*B$2:K$2)/SOMMEPROD(SIGNE(B3:K3)*B$2:K$2);"")

Cordialement
 

polog57

XLDnaute Nouveau
En fait je veux une moyenne par élève.
L'élève paul a eu 7 au test 1 au coef.1, 8 au test 2 au coef.2, absent au test 3, et 9 au test 4 coef.0.3.
L'élève Jacques a eu 8 au test 1, absent au test 2, 7 au test 3 et 10 aau test 4.
 

R@chid

XLDnaute Barbatruc
Re,
En fait je veux une moyenne par élève.
L'élève paul a eu 7 au test 1 au coef.1, 8 au test 2 au coef.2, absent au test 3, et 9 au test 4 coef.0.3.
L'élève Jacques a eu 8 au test 1, absent au test 2, 7 au test 3 et 10 aau test 4.
oui c'est clair, donc pour les tests où l'élève est absent on en compte pas, et du coup, Paul aura (7*1+8*2+9*0.3)/(1+2+0.3)=25.7/3.3=7.78 ?
 

polog57

XLDnaute Nouveau
Re,

oui c'est clair, donc pour les tests où l'élève est absent on en compte pas, et du coup, Paul aura (7*1+8*2+9*0.3)/(1+2+0.3)=25.7/3.3=7.78 ?
Oui, c'est bien cela. Je veux choisir le nombre de tests que je veux faire par trimestre ainsi que le coefficient, et bien sûr ne pas prendre en compte les élèves absents.
Merci de votre aide
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas