identifier une valeur en fonction de deux condition ( j'ai tout essayer mais en vain)

boumlaik

XLDnaute Nouveau
Bonjour;
j'ai un problème qui va être pour vous un jeux d'enfant, en fait j'ai deux tableau le 1er il y a les débits et le 2eme y a les crédits et je veux identifier les numéros compte qui ont un débit d'un montant et pas un crédit du mm montant et vis versa. j’espère que j'étai bien claire dans mes explications .
je vous remercie d'avance
 

Fichiers joints

Gurgeh

XLDnaute Occasionnel
Re : identifier une valeur en fonction de deux condition ( j'ai tout essayer mais en

Salut boumlaik,

en fait tu veux effectuer un recherchev avec deux conditions. Je te conseille la lecture du site de J.Boisgontier sur le sujet : recherchev 2 conditions

Voir fichier joint : la fonction
Code:
{=SIERREUR(INDEX($I$2:$I$6;EQUIV(1;($G$2:$G$6=A2)*($H$2:$H$6=B2);0))=-C2;FAUX)}
placée en E2 devrait correspondre à ton besoin.

Attention, elle ne regarde que la première occurence du couple N°compte/Date, donc si il y a plusieurs opérations avec le même numéro de compte et la même date ça risque de ne pas marcher...

A ta dispo si questions sur la formule.

Gurgeh
 

Fichiers joints

boumlaik

XLDnaute Nouveau
Re : identifier une valeur en fonction de deux condition ( j'ai tout essayer mais en

Merci bcp ça marche en tout cas! t'es un génie! merci encore
 

boumlaik

XLDnaute Nouveau
Re : identifier une valeur en fonction de deux condition ( j'ai tout essayer mais en

Bonsoir

je reviens vers toi! pour savoir si possible de faire la même chose sans prendre en compte la date?
j'ai essayé mais je suis trop nul , j'ai pas réussi
merci bcp
Cordialement
 

Gurgeh

XLDnaute Occasionnel
Re : identifier une valeur en fonction de deux condition ( j'ai tout essayer mais en

Salut boumlaik,

Dans ce cas je te conseille de passer par la fonction NB.SI.ENS, qui regarde le nombre de fois où plusieurs conditions sont remplies :
En E2 : =NB.SI.ENS($I$2:$I$6;-C2;$G$2:$G$6;A2) va te donner le nombre de lignes dans ton tableau en G:J où tu trouves à la fois le numéro de compte et un montant opposé à celui que tu cherches.

Je ne sais plus si dans Excel 2007 il y a cette fonction. Dans ce cas, tu peux utiliser SOMMEPROD
En E2 : =SOMMEPROD(--($G$2:$G$6=A2);--($I$2:$I$6=-C2))

Voir fichier joint.

Gurgeh
 

Fichiers joints

boumlaik

XLDnaute Nouveau
Re : identifier une valeur en fonction de deux condition ( j'ai tout essayer mais en

Merci bcp Gurgeh c'est exactement ce que je cherche!
e te remercie encore pour ton aide
Cordialement
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas