XL 2016 Identifier doublons, les compter et les trier du + vers -

Speid29

XLDnaute Nouveau
Bonjour la communauté,

alors j'ai recherché dans les posts existants mais j'ai pas réussi à retranscrire dans mon cas...
J'ai donc une liste de références produits en colonne et je cherche à:

1/ identifier les doublons
2/ compter le nombre de fois qu'ils ressortent en fonction de leur valeur
3/ ressortir ces valeurs et les trier en fonction du nbre de fois qu'ils apparaissent de manière décroissante

J'espère avoir été clair… Si pas assez, je suis à votre dispo
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Bonsoir @ tous,
avec une formule matricielle en D2 :
VB:
=SIERREUR(INDEX(A$2:A$71;EQUIV(GRANDE.VALEUR(SI(EQUIV(A$2:A$71;A$2:A$71;0)=LIGNE(INDIRECT("1:"&LIGNES(A$2:A$71)));NB.SI(A$2:A$71;A$2:A$71));LIGNES($2:2));SI(EQUIV(A$2:A$71;A$2:A$71;0)=LIGNE(INDIRECT("1:"&LIGNES(A$2:A$71)));NB.SI(A$2:A$71;A$2:A$71));0));"")
@ valider par Ctrl+Shift+Enter
@ tirer vers le bas


Cordialement
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas