Résolu Help pour la création d'une formule conditionnelle texte et chiffre

celinelle

XLDnaute Nouveau
Bonjour à tous,

Je suis nouvelle sur le forum, je vous remercie par avance pour votre aide.
J'ai besoin de créer une formule de calcul ...
je vais tenter de m'expliquer :
en A1 on peut avoir les termes JOUR ou NUIT ou SOIR.
En fonction du terme présent en A1 nous devons faire apparaître un chiffre différent en A2. si A1=JOUR alors B1=8,5 ou si A1=SOIR alors B1=16,25 et dernière possibilité si A1=NUIT alors B1=23,75
et si A1 est vide ou contient un autre terme alors B1 est vide

Merci beaucoup

Céline
 
Ce fil a été résolu! Aller à la solution…

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour, celinelle et bienvenue.

Essayez :
=SIERREUR(CHOISIR(EQUIV(A1;{"JOUR";"NUIT";"SOIR"};1);8,5;16,25;23,75);"")

Edit : Bonjour Chris24
 
Ce message a été identifié comme étant une solution!
Dernière édition:

Chris24

XLDnaute Impliqué
Supporter XLD
Bonjour celinelle, Victor21

Une autre avec Index et Equiv

=SIERREUR(INDEX({8,5;16,25;23,75};EQUIV(A1;{"JOUR";"SOIR";"NUIT"};0));"")


Cdt
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour celinelle, Chris24, Victor21 :) ,

Principalement pour saluer mes petits camarade de jeu et pour le fun une autre formule


VB:
=(A1="soir")*23,75+(A1="nuit")*16,25+(A1="jour")*8,5
Cordialement
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas