Générer une liste sans doublon sans macro

A1B2C3

XLDnaute Nouveau
Bonjour,

Existe-t-il une manière de créer une liste sans doublons à partir d'une liste contenant elle des doublons? Le tout sans macro bien sur!
Ex: en colonne A des noms reviennent plusieurs fois, je souhaite qu'ils n'apparaissent qu'une seule fois dans une autre colonne.

Le fichier joint montre ce que je voudrais faire.

Cordialement,

A1B2C3
 

Fichiers joints

A1B2C3

XLDnaute Nouveau
Re : Générer une liste sans doublon sans macro

Merci pour votre aide! Je n'arrive juste pas à comprendre l'argument "Liste" dans la formule.
 
Dernière édition:

Victor21

XLDnaute Barbatruc
Supporter XLD
Re : Générer une liste sans doublon sans macro

Bonjour à tous.

Je ne comprends pas l'argument en violet qui "Liste" qui ne correspond pas à un numéro de cellule!
Pourtant, Iznogood1 :) a pris soin d'indiquer la définition du nom défini "Liste" directement sur la feuille.
Regardez dans le volet Formules, Gestionnaire de noms.
 

david84

XLDnaute Barbatruc
Re : Générer une liste sans doublon sans macro

Bonsoir,
pour éviter l'affichage des 0 :
Code:
=INDEX($A:$A;MIN(SI(NB.SI(D$1:D1;Liste)=0;LIGNE(Liste);LIGNES(Liste)+LIGNE(Liste))))&""
A+
 

A1B2C3

XLDnaute Nouveau
Re : Générer une liste sans doublon sans macro

La formule ayant un argument "$A$A", il est impossible de faire une liste sans doublon dans la même colonne mais en dessous de la première. J'ai essayé de modifier la formule mais cela ne fonctionne pas. Comment réaliser la même chose mais en créant une liste en dessous de la première (cf. image) ? Sans titre.jpg
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Re : Générer une liste sans doublon sans macro

Bonjour,
remplacer $A:$A par $a$1:$a$14 dans la formule ET dans la définition de la zone "Liste"
Cordialement
 

A1B2C3

XLDnaute Nouveau
Re : Générer une liste sans doublon sans macro

Merci pour votre réponse. En fait j'ai déjà fait cette opération mais ça ne marche pas (ou alors je m'y prends mal)!
 

david84

XLDnaute Barbatruc
Re : Générer une liste sans doublon sans macro

Bonsoir,
se placer en A20 :
Code:
=SI(LIGNE(1:1)>SOMME(1/NB.SI(Liste;Liste));"";INDEX(A$1:A$14;MIN(SI(NB.SI(A$19:A19;Liste)=0;LIGNE(Liste)))))
Validation matricielle.
A+
 

david84

XLDnaute Barbatruc
Re : Générer une liste sans doublon sans macro

C'est normal car Liste est définie via DECALER et NBVAL prend en charge toute la colonne A.
tu peux éventuellement la redéfinir comme cela
Code:
=DECALER(Feuil1!$A$2;;;NBVAL(Feuil1!$A1:$A18)-1)
mais cela n'a pas beaucoup de sens.
La meilleur solution est de placer la formule sur une autre colonne que la colonne A qui doit être réservée à Liste.
A+
 

Discussions similaires


Haut Bas