Générer une liste à partir d'un critère de nombre

A1B2C3

XLDnaute Nouveau
Bonjour,

Je souhaiterais générer une liste de prénoms à partir du nombre d'occurrence de ces prénoms pour qu'il aient chacun leur propre ligne.
Ex : si J'ai en A1 Henri et en B1 3, ça veut dire que j'ai 3 Henri. Je souhaite une formule qui permettrait de générer autant de lignes que de Henri soit en C1 Henri, en C2 Henri, en C3 Henri.

L'Excel joint sera plus clair je pense.

Bien à vous,
 

Fichiers joints

  • 7.9 KB Affichages: 20

job75

XLDnaute Barbatruc
Bonsoir A1B2C3,

En F2 :
Code:
=A2
En F3 :
Code:
=SI(NB.SI(F$2:F2;F2)=INDEX(B:B;EQUIV(F2;A:A;0));INDEX(A:A;EQUIV(F2;A:A;0)+1);F2)
A+
 

Fichiers joints

Discussions similaires


Haut Bas