Toutes versions fractionner les données d'un cases dans plusieurs

fractionner les données d'un cases dans plusieurs

  • toutes

    Votes: 0 0.0%
  • OK

    Votes: 0 0.0%

  • Nombre total d'électeurs
    0

PETIT YANNICK

XLDnaute Nouveau
Bonjour et bonne année à tous,
Je vous demande votre aide car j'ai un fournisseur qui peut nous fournir un tableau de chiffrage avec des données importantes dans la même case. Il faut que je recupère les données d'une case et repartir une partie des données dans un case et une autre partie dans une autre case.
Je dois récupérer ce qu'il y a avant deux repères .
Dans mon cas il faut que je récupère ce qu'il y a avant DET ou MON et récupérer DET ou MON plus 5 chiffres.
Je ne connais pas la formule OU

dans le fichier joint la désignation 1 sont les données a retravailler , la colonne désignation 2 et plan indice est le résultat souhaité.

SUPPORT CARTE AXE Z DET53971-A3 / DET53971 /// SUPPORT CARTE AXE Z /// DET53971-A3
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour PETIT YANNICK, bienvenue sur XLD,

Votre formule en B2 semble convenir, par contre en C2 je mettrai :
Code:
=SIERREUR(STXT(A2;SI(ESTNUM(CHERCHE("DET";A2));CHERCHE("DET";A2);CHERCHE("MON";A2));11);"")
A+
 

PETIT YANNICK

XLDnaute Nouveau
Bonjour ,votre formule fonctionne parfaitement.merci.
Par contre je n arrive pas a la comprendre.
Est ce que vous pouvez m expliquer son fonctionnement ?
Merci d avance
 

job75

XLDnaute Barbatruc
Par rapport à votre formule en C2 :

- j'ai ajouté un test SI pour fonctionner soit avec DEST soit avec MON

- j'ai ajouté SIERREUR pour le cas où il n'y a niDEST ni MON.

A+
 

Discussions similaires


Haut Bas