XL 2010 Formules si avec des conditions

jacky49

XLDnaute Impliqué
Bonsoir le forum,

j'ai cette formules
VB:
'=SI(GB8="";"";SI($B$4="Grand";RECHERCHEV(GB8;Cad!$B$7:$I$105;8;FAUX);"0"))
qui fonctionne mais j'aimerais ajouter 1 condition avec 2 choix
En B4 = "Grand",et en C4 = "3 M " ou "2 M"
j'ai donc essayé ceci mais il me met # de valeur
Code:
'=SI(GB8="";"";SI($B$4="Grand";SI(C4="3 M";OU(C4="2 M";RECHERCHEV(GB7;Cad!$B$7:$I$105;8;FAUX);"0"))))
j'espère avoir été assez explicite car mon fichier est très gros et avec des données confidentiel
merci de votre aide
 

BrunoM45

XLDnaute Barbatruc
bonsoir

A essayer
VB:
=SI(GB8="";"";SI(ET($B$4="Grand";OU(C4="3 M";C4="2 M"));RECHERCHEV(GB8;Cad!$B$7:$I$105;8;FAUX);"0"))
A+
 

jacky49

XLDnaute Impliqué
bonsoir

A essayer
VB:
=SI(GB8="";"";SI(ET($B$4="Grand";OU(C4="3 M";C4="2 M"));RECHERCHEV(GB8;Cad!$B$7:$I$105;8;FAUX);"0"))
A+
Bonsoir BrunoM45, le forum,

merci beaucoup, cela fonctionne impeccable
j'ai une autre question mais ce n'est peut-être pas possible, peut-on le faire en VBA , c'est à dire si les conditions sont remplies on copie la 8 ème colonne de I7 à I105 en GG 7 à GG105
merci de votre aide
 

Discussions similaires


Haut Bas