XL 2016 Formule sous plusieurs conditions

loicoss

XLDnaute Junior
Bonjour le forum,

je me gratte la tête depuis plusieurs heures pour réaliser une formule suivant plusieurs conditions dans un tableau de données.

Voici mon besoin :

Je souhaite compter la famille du code "famille 1" si le responsable est "resp 1" et la méthode est "air". Sachant que je souhaite compter la "famille 1" seulement une fois par jour (si la famille répondant aux premières conditions ressort plusieurs fois dans une même journée (date) il ne faut la compter qu'une seules fois).

J'ai essayé avec différentes formules SI, ET, OU, et je ne m'en sors pas.

Pourriez-vous m'apporter une aide svp ?

En vous remerciant par avance.

J'ai mis en pièce jointe le fichier en exemple.
 

Pièces jointes

  • exemple.xlsx
    11.3 KB · Affichages: 11
Solution
re,
Bonjour l'ami JHA :)

Pour qu'elle s'appuie vraiment sur la date modifier les 2 EQUIV() de cette façon

=SOMME(SI(FREQUENCE(SI((H2:H31=J8)*(C2:C31=K8)*(E2:E31=L8);EQUIV(B2:B31;B2:B31;0));EQUIV(B2:B31;B2:B31;0))>0;1))



Cordialement

JHA

XLDnaute Barbatruc
Bonjour à tous,

Ci-joint un exemple avec la table mise sous format tableau.
Insertion d'une colonne pour compter la requête sans doublon
Insertion de trois segment "Responsable", "Moyen" et "Famille du code" pour filtrer suivant vos critères de choix.
Une formule sous.total pour donner le résultat souhaité.
La colonne comptage peut être masquée.

Edit: Bonjour Jocelyn :) , content de te croiser sur le forum.

JHA
 

Pièces jointes

  • exemple (2).xlsx
    18.5 KB · Affichages: 6
Dernière édition:

Jocelyn

XLDnaute Barbatruc
re,
Bonjour l'ami JHA :)

Pour qu'elle s'appuie vraiment sur la date modifier les 2 EQUIV() de cette façon

=SOMME(SI(FREQUENCE(SI((H2:H31=J8)*(C2:C31=K8)*(E2:E31=L8);EQUIV(B2:B31;B2:B31;0));EQUIV(B2:B31;B2:B31;0))>0;1))



Cordialement
 

Discussions similaires

Statistiques des forums

Discussions
291 730
Messages
1 917 541
Membres
179 713
dernier inscrit
Ranya
Haut Bas