Résolu Formule sommeprod avec matrice "annee en cours"

Mkonate

XLDnaute Nouveau
Bonjour, j'ai fait une sommeprod sur excel pour trouver une certaine valeur avec comme année 2019 :

Code:
=SOMMEPROD((MOIS(RASTATT!$G$8:$G$66518)=C3)*(ANNEE(RASTATT!$G$8:$G$66518)=2019)*(RASTATT!$K$8:$K$66518))+SOMMEPROD((RASTATT!$L$8:$L$66525="")*(MOIS(RASTATT!$G$8:$G$66525)=C3)*(ANNEE(RASTATT!$G$8:$G$66525)=2019)*(RASTATT!$J$8:$J$66525))

Je voulais modifier le 2019 est avoir l'année en cours afin que le document puisse être utiliser après 2019. J'ai essayé avec la formule :

Code:
=SOMMEPROD((MOIS(RASTATT!$G$8:$G$66518)=C3)*(ANNEE(RASTATT!$G$8:$G$66518)=annee(aujourdhui()))*(RASTATT!$K$8:$K$66518))+SOMMEPROD((RASTATT!$L$8:$L$66525="")*(MOIS(RASTATT!$G$8:$G$66525)=C3)*(ANNEE(RASTATT!$G$8:$G$66525)=2019)*(RASTATT!$J$8:$J$66525))
Mais je trouve 0 comme résultat.


Quelqu'un pourrait-il m'aider sur la formule? Merci d'avance
 

Roblochon

XLDnaute Accro
Bonjour,

Il est probable que votre sommeprod puisse être avantageusement remplacer par un somme.si.ens mais sans fichier exemple, comment l'affirmer ou corriger vos formules.

bon après-midi
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas