formule somme.si.ens qui ne fonctionne pas

denisR

XLDnaute Nouveau
jbonjour

je bloque sur un probleme idiot
la formule SOMME.SI.ENS ne fonctionne pas
Quelqu'un pourrait il regarder et essayer chez lui
quand je supprime le critere de la colonne B cela fonctionne sinon cela me donne un resultat incoherent

merci pour votre aide

Denis
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour denisR, JHA,

Oui, les résultats en E11 (338) et F11 (2915) sont corrects.

A+
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Sans un extrait de ton fichier qui cause problème, il est difficile de te donner une réponse.

JHA
 

job75

XLDnaute Barbatruc
Vérifiez bien que des espaces superflus n'ont pas été mis dans les données...
 

BrunoM45

XLDnaute Barbatruc
Bonjour le fil
A ben tu m'étonnes que ça ne marche pas

Tu ne connais pas la touche F2 qui permet d'entrer en mode édition sur une formule et de voir les colonnes concernées
=SOMME.SI.ENS(E$2:E$159;$D$2:$D$159;$D161;$B$2:$B$159;$B161;$G$2:$G$159;$C161)
Pourquoi prendre la colonne G pour tester "comparable" !?
 

denisR

XLDnaute Nouveau
bonsoir

Non je ne connais pas la touche F2 et j'ai essayé mais cela ne fonctionne pas chez moi
je remets le fichier complet d'origine avec toutes les formules
pour tester comparable j'utilise la colonne S
cette fonction je l'utilise tous les jours pour des cas plus complexes mais là je bloque je ne comprends pas pourquoi il sort 0 sur les lignes
de totaux en bas
ça fonctionne pour une ligne pas pour les autres
 

Fichiers joints

BrunoM45

XLDnaute Barbatruc
Re,
Bon déjà tu as changé ta formule, c'est mieux ;)
Tu es sur Mac !? Tu n'as pas indiqué ta version d'Excel dans ton profil..

Sinon édites tes cellules de B162 à B164 tu as un espace après qu'il faut supprimer
 

denisR

XLDnaute Nouveau
Merci Merci Merci
Enfer et damnation
Je vais retrouvé, dans ma société, l'empaffé qui m'a collé des espaces
je soupçonne une blague du 1er avril
j'ai perdu 2h pour 4 espaces

Encore merci pour votre patience
 

Discussions similaires


Haut Bas