Microsoft 365 Formule si ou avec plusieurs textes définis

Palquia

XLDnaute Nouveau
Bonjour tout le monde

J'ai un souci avec une formule où je dois chercher des textes différents pour ensuite extraire les lignes
La formule que j'ai mise m'indique que j'ai mis trop de paramètres.
Pouvez vous m'aider ?

La phrase étant : si je trouve le mot NUMERIQUE ou DIGITAL ou ROBOTIQUE alors je mets une X (par exemple dans la cellule A2)

J'ai proposé cela mais cela ne convient pas :

SI(OU(NB.SI(A2;"*NUMERIQUE*";"*DIGITAL*";"*ROBOTIQUE*");"X";"")))

Merci par avance pour vos réponses
Bonne fin de journée
 
Solution
Bonjour,
comme ceci peut-être,
un morceau de fichier est souvent demandé pour connaître de petits détails,respect ou non de la casse, liste de choix ou entrée manuelle.

VB:
=SI(OU(NB.SI(A2;"*NUMERIQUE*");NB.SI(A2;"*DIGITAL*");NB.SI(A2;"*ROBOTIQUE*"));"X";"")
Bonjour,
Merci beaucoup, elle fonctionne parfaitement et la petite VB pour copier la formule est géniale.
Tout fonctionne parfaitement.
Bonne journée

polyteis

XLDnaute Occasionnel
Bonjour tout le monde

J'ai un souci avec une formule où je dois chercher des textes différents pour ensuite extraire les lignes
La formule que j'ai mise m'indique que j'ai mis trop de paramètres.
Pouvez vous m'aider ?

La phrase étant : si je trouve le mot NUMERIQUE ou DIGITAL ou ROBOTIQUE alors je mets une X (par exemple dans la cellule A2)

J'ai proposé cela mais cela ne convient pas :

SI(OU(NB.SI(A2;"*NUMERIQUE*";"*DIGITAL*";"*ROBOTIQUE*");"X";"")))

Merci par avance pour vos réponses
Bonne fin de journée
bonjour

essaye cela
=SI(OU(B2="numérique";B2="digital";B2="robotique");"x";"")
 

st007

XLDnaute Accro
Bonjour,
comme ceci peut-être,
un morceau de fichier est souvent demandé pour connaître de petits détails,respect ou non de la casse, liste de choix ou entrée manuelle.

VB:
=SI(OU(NB.SI(A2;"*NUMERIQUE*");NB.SI(A2;"*DIGITAL*");NB.SI(A2;"*ROBOTIQUE*"));"X";"")
 

Palquia

XLDnaute Nouveau
Bonjour,
comme ceci peut-être,
un morceau de fichier est souvent demandé pour connaître de petits détails,respect ou non de la casse, liste de choix ou entrée manuelle.

VB:
=SI(OU(NB.SI(A2;"*NUMERIQUE*");NB.SI(A2;"*DIGITAL*");NB.SI(A2;"*ROBOTIQUE*"));"X";"")
Bonjour,
Merci beaucoup, elle fonctionne parfaitement et la petite VB pour copier la formule est géniale.
Tout fonctionne parfaitement.
Bonne journée
 

Discussions similaires

Réponses
3
Affichages
279

Statistiques des forums

Discussions
288 632
Messages
1 893 633
Membres
169 984
dernier inscrit
mdemrs
Haut Bas