XL 2019 Formule SI imbriqué.

AIXELS

XLDnaute Nouveau
Supporter XLD
Bonjour à tous les amis du Forum. :)
Je reviens vers vous, pour une aide sur une formule de "SI imbriqué".
Je vous joins un fichier. Si c'est Lundi, Jeudi = 3:00
Samedi et Dimanche = 0:00
Le reste des jours = 1:00

Merci pour votre aide. Bien cordialement.
 

Pièces jointes

  • FORMULE SI IMBRIQUÉE.xlsx
    24.2 KB · Affichages: 7

djidji59430

XLDnaute Barbatruc
Si tu veux travailler sur des dates, commence par mettre partout des vraies dates excel !
Lun., ça ne veut rien dire a excel (c'est pas un jour, c'est du texte !)
"3:00", ça ne veut rien dire a excel (c'est pas une heure, c'est du texte !)
tu commence par une date 01/01/2021 que tu tritures avec des format personnalisés pour obtenir ce que tu désires,
exp
01/01/2021 en format personalise jjj, ça te donne lun, avec jjjj, ça te donne lundi, sauf qu'on peut toujours faire des calculs avec ces cellules.
On ne fait pas de calculs avec du texte !

Crdlmt
 

Yeahou

XLDnaute Accro
Supporter XLD
Bonjour Aixels, djidji59430

D'accord avec djidji et les si imbriqués ne sont pas forcément la meilleure solution.
en exemple, dans le fichier joint, changes la date en A1 (au 01/05/21 par exemple), ton tableau se mettra à jour tout seul

Bien cordialement
 

Pièces jointes

  • FORMULE SI IMBRIQUÉE - Copie.xlsx
    16.4 KB · Affichages: 4

AIXELS

XLDnaute Nouveau
Supporter XLD
Bonjour djidji59430, Yeahou, Victor21 et tous les Amis du Forum.
Merci pour vos réponses respectives. 👍
J'opterai pour celle de @Yeahou.
Car elle automatise la mise à jour du calendrier. 📆
Effectivement, je n'ai pas formaté les différents données en date, désolé. 😔
Je vous soumets un problème que je rencontre pour un format conditionnel

à savoir colorer en vert la date du jour. Voir fichier joint.
J'ai essayé la formule :
=C$4=JOUR(AUJOURDHUI())
que je recopie sur les dates du mois, mais ça ne fonctionne pas. ❓
Merci pour votre aide.
Bien cordialement. :)
 

Pièces jointes

  • FORMULE SI IMBRIQUÉE - Yeahou.xlsx
    51.7 KB · Affichages: 2

djidji59430

XLDnaute Barbatruc
J'ai essayé la formule : =C$4=JOUR(AUJOURDHUI())
non, ta formule c'est ="C$4=JOUR(AUJOURDHUI())"
et avec des "", elle ne peut pas fonctionner. Tu a rentré ta formule sans le = et excel t'as mis un =, mais avec des guillemets .....
A l'origine une mauvaise syntaxe.
De toute façon, ça ne pouvait pas fonctionner.
$c4=01/04/2021
jour(aujourdhui()) =1

Crdlmt
 
Dernière édition:

AIXELS

XLDnaute Nouveau
Supporter XLD
Merci pour vos réponses respectives. 👍
J'opterai pour celle de @Yeahou.
Car elle automatise la mise à jour du calendrier. 📆

Bonjour à tous les Amis du Forum. :)
Je reviens vers vous pour peaufiner le fichier ci-joint.
Je suis confronté à deux soucis à savoir :

1) Affichage de message d'erreur pour le mois de Février.
J'ai essayé de le résoudre, mais je n'y arrive pas.
J'ai tout expliqué sur le fichier joint.

2) Comment faire une copie du fichier dans mon application
"sans qu'il garde les liaisons. Il fait référence au fichier d'origine.

Il y'a tellement de subtilités dans Excel, que si elle existe, je ne la connais pas.

Merci pour aide.
Bien cordialement.
 

Pièces jointes

  • FORMULE SI IMBRIQUÉE - Yeahou.xlsx
    39.9 KB · Affichages: 6

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour tout le monde,
En PJ un essai.
Pour les dates >28 ( AC2:AE2 ) mettre :
VB:
=SIERREUR(SI(JOUR(AB2+1)>JOUR(AB2);AB2+1;"");"")
ce qui supprime les erreurs pour les 29,30 et 31 février.
Pour les liens, il suffit de les supprimer, et retirer toute référence au fichier xls d'origine.
 

Pièces jointes

  • Aixels.xlsx
    17.4 KB · Affichages: 3

AIXELS

XLDnaute Nouveau
Supporter XLD
Bonjour tout le monde,
En PJ un essai.
Pour les dates >28 ( AC2:AE2 ) mettre :
VB:
=SIERREUR(SI(JOUR(AB2+1)>JOUR(AB2);AB2+1;"");"")
ce qui supprime les erreurs pour les 29,30 et 31 février.
Pour les liens, il suffit de les supprimer, et retirer toute référence au fichier xls d'origine.
Bonjour sylvanu
erci pour ta réponse. Le problème est réglé pour l'affichage des erreurs, mais
la formule de calcul du nombre d'heures ne fonctionnent plus à savoir
Lundi et Jeudi = 3:00 - Samedi et Dimanche = 0 - Mardi, Mercredi, vendredi = 1:00

Comme indiqué sur le fichier joint.
Bien cordialement. :)
 

Discussions similaires

Statistiques des forums

Discussions
286 624
Messages
1 877 552
Membres
160 770
dernier inscrit
pronostics.store
Haut Bas