XL 2016 formule SI et #VALEUR

vivi21

XLDnaute Nouveau
Bonjour,

Je suis bloquée sur une formule. J'ai une colonne comportant une liste déroulante. Sur cette fiche, j’affiche ce type de texte dans ma colonne "G2" 85_test_vivi ou 8B_testamelie 7C_test_vivi.
Dans une autre colonne je récupère les deux premiers caractères dans ma colonne "D2" c'est à dire 85 ou 8B ou 7C par la formule suivante :

= SI(G2="";"";GAUCHE(G2;2)*1
J'affiche "*1" car ensuite je doit par une rechercheV recherche le code de ma cellule D2 pour afficher un contenu dans la cellule E2

Le problème c'est que cette formule ne fonctionne pas pour 8B et 7C ou cela m'affiche #VALEUR!. Si j'enlève "*1" cela fonctionne.

je n'arrive pas à combiner avec des SI que si j'ai #VALEUR! il faut afficher (gauche(G2;2))

Pouvez-vous m'aiguiller sur une formule ?

Merci.

vivi
 

xUpsilon

XLDnaute Impliqué
Bonjour,

Pourquoi avoir besoin de ce *1 pour la suite, je ne vois pas en quoi 8B ne pourrais pas être utilisé dans un recherchev ?
D'autant plus que effectivement, *1 va forcer un nombre, sauf que écrire 8B sous forme de nombre bah c'est pas évident.

Bonne continuation
 

WTF

XLDnaute Occasionnel
Et en essayant la formule suivante en D2 :
VB:
=SIERREUR(SI(G2="";"";GAUCHE(G2;2)*1);SI(G2="";"";GAUCHE(G2;2)))
Bon courange
 

vivi21

XLDnaute Nouveau
Bonjour XUpsilon,

J'avais trouvé la solution de mon *1 pour faire fonctionner ma rechercheV car je vais rechercher sur une feuille qui est en liaison avec un autre fichier.

Bonjour WTF,

Merci pour cette solution, cette formule fonctionne j'avais bien pensé à SIERREUR mais je n'arrivais pas à la mettre correctement.


Merci infiniment pour votre aide qui va me faire avancer dans la construction de mon ficher.

Vivi
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas