Formule SI à conditions multiples

philouis

XLDnaute Junior
Bonjour le forum,

Voici une formule SI à conditions multiples que je n'arrive pas à écrire correctement et complétement.

Soit :
- un indice annuel (valeur fixe) en A2 de 30130
- en B2 le quotient familial de l'adhérent (valeur variable selon les adhérents) en B2 (dans l'exemple 20800)
- en C2 le prix de base de l'activité; valeur également varialbe selon l'activité (dans l'exemple 800 €)

Le montant restant à la charge de l'adhérent (D2) est égal au prix de l'activité divisé par l'indice et multiplié par 100, sachant que la valeur obtenue ne peut pas être inférieure à 30% du prix de l'activité ni être supérieure à 65% du prix de l'activité.

Le calcul se fait en appliquant la formule suivante :

D2 = SI((C2/A2*100)*(B2/100)<C2*35%;C2*35%;SI((C2/A2*100)*(B2/100)>C2*70%;C2*70%;(C2/A2*100)*(B2/100)))

Aux règles précédentes il convient d'ajouter une condition supplémentaire :

Le prix de l'activité doit être compris entre 0 et 1000 €. Pour une activité d'un montant supérieur à 1000 € le calcul se fera sur la base d'une activité égale à 1000 €.

Un exemple se trouve dans le fichier joint.

Merci d'avance pour votre aide
 

Pièces jointes

  • FORMULE SI à conditions multiples.xls
    24 KB · Affichages: 57
  • FORMULE SI à conditions multiples.xls
    24 KB · Affichages: 60
  • FORMULE SI à conditions multiples.xls
    24 KB · Affichages: 60

Jocelyn

XLDnaute Barbatruc
Re : Formule SI à conditions multiples

Bonjour le Forum,
Bonjour philouis,

un essai en fichier joint

Cordialement

EDIT : bonjour victor :)
 

Pièces jointes

  • FORMULE SI à conditions multiples.xls
    36.5 KB · Affichages: 55
  • FORMULE SI à conditions multiples.xls
    36.5 KB · Affichages: 57
  • FORMULE SI à conditions multiples.xls
    36.5 KB · Affichages: 66
Dernière édition:
Haut Bas