Formule pour récupérer données dans un tableau selon 2 conditions

vatsyayana

XLDnaute Nouveau
Bonjour à tous !

L'un d'entre vous saurait-il me dire quelle formule je dois utiliser pour récupérer un montant dans un tableau selon le pays de la commande et le nombre de produits commandés ?


Ça fait des heures que je cherche, je ne trouve pas... J'espère que vous saurez m'aider ! Merci d'avance !


Je vous ai mis un exemple sur Google Drive : https://docs.google.com/spreadsheets/d/1mDZe6jcm1rIq4gmyjRU10OpBS2e2bkexWYX8MtYrFUA/edit?usp=sharing
 

vmax01

XLDnaute Occasionnel
bonjour, une piste ....
une formule a retravailler mais c'est une piste.... avec le fichier explicatif et les formules installées
 

Fichiers joints

vmax01

XLDnaute Occasionnel
je renvois le fichier j'ai eu un problème sur la 1 er cellule
la formule est
=SOMME(SI(C2="";0;DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);1)*C2);SI(D2="";0;DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);2)*D2);SI(E2="";0;DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);3)*E2))
 

Fichiers joints

vatsyayana

XLDnaute Nouveau
OMG ! Elle est pas simple comme formule ^^
Bon, je vais essayer de la comprendre et d'appliquer ! Merci beaucoup pour le coup de pouce ;)
 

vatsyayana

XLDnaute Nouveau
Ça ne donne pas du tout le bon résultat dans ton fichier, il doit y avoir un problème.

Dans la cellule F2, on doit récupérer la donnée dans I3
Dans la cellule F3, on doit récupérer la donnée dans L4
Dans la cellule F4, on doit récupérer la donnée dans J5
Dans la cellule F5, on doit récupérer la donnée dans K3
 

vmax01

XLDnaute Occasionnel
autant pour moi je n’avais pas compris ton raisonnement
place cette formule en F2 et tu l’incréments vers le bas

=DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);SOMME(C2:E2))

bonne soirée.
 

vatsyayana

XLDnaute Nouveau
Sais-tu comment éviter l'erreur #VALUE! quand les cellules avec le nombre de produits sont vides ?
Ayant 3 tableaux comme ceux de l'exemple différents, j'ai additionné 3 fois la formule, ce qui fonctionne très bien, mais si une commande ne comporte pas un produit dans chacun des 3 tableaux, cela me met cette erreur.
 

vmax01

XLDnaute Occasionnel
tu mets cette formule en F2 et incrémentation

=SI(SOMME(C2:E2)=0;0;(DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);SOMME(C2:E2))))

bonne soirée
 

Discussions similaires


Haut Bas