1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Formule pour récupérer données dans un tableau selon 2 conditions

Discussion dans 'Forum Excel' démarrée par vatsyayana, 5 Décembre 2018.

  1. vatsyayana

    vatsyayana XLDnaute Nouveau

    Inscrit depuis le :
    17 Octobre 2014
    Messages :
    10
    "J'aime" reçus :
    0
    Bonjour à tous !

    L'un d'entre vous saurait-il me dire quelle formule je dois utiliser pour récupérer un montant dans un tableau selon le pays de la commande et le nombre de produits commandés ?


    Ça fait des heures que je cherche, je ne trouve pas... J'espère que vous saurez m'aider ! Merci d'avance ! [​IMG]

    Je vous ai mis un exemple sur Google Drive : https://docs.google.com/spreadsheets/d/1mDZe6jcm1rIq4gmyjRU10OpBS2e2bkexWYX8MtYrFUA/edit?usp=sharing
     
  2. Chargement...

    Discussions similaires - Formule récupérer données Forum Date
    XL 2007 Formule pour récupérer certaines données... Forum Excel 23 Novembre 2016
    XL 2010 Formule pour récupérer les données d'un autre classeur Forum Excel 18 Octobre 2016
    Macro ou formules pour récupérer des données selon critères... Forum Excel 4 Novembre 2014
    formules pour recuperer des donnees sur 12 feuilles Forum Excel 12 Juin 2012
    VBA, Formules ?! Récupérer les données par rapport à 2 valeurs, pour tableau & graphi Forum Excel 21 Mars 2012

  3. vmax01

    vmax01 XLDnaute Occasionnel

    Inscrit depuis le :
    17 Février 2008
    Messages :
    183
    "J'aime" reçus :
    7
    bonjour, une piste ....
    une formule a retravailler mais c'est une piste.... avec le fichier explicatif et les formules installées
     

    Pièces jointes:

  4. vmax01

    vmax01 XLDnaute Occasionnel

    Inscrit depuis le :
    17 Février 2008
    Messages :
    183
    "J'aime" reçus :
    7
    je renvois le fichier j'ai eu un problème sur la 1 er cellule
    la formule est
    =SOMME(SI(C2="";0;DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);1)*C2);SI(D2="";0;DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);2)*D2);SI(E2="";0;DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);3)*E2))
     

    Pièces jointes:

  5. vatsyayana

    vatsyayana XLDnaute Nouveau

    Inscrit depuis le :
    17 Octobre 2014
    Messages :
    10
    "J'aime" reçus :
    0
    OMG ! Elle est pas simple comme formule ^^
    Bon, je vais essayer de la comprendre et d'appliquer ! Merci beaucoup pour le coup de pouce ;)
     
  6. vatsyayana

    vatsyayana XLDnaute Nouveau

    Inscrit depuis le :
    17 Octobre 2014
    Messages :
    10
    "J'aime" reçus :
    0
    Ça ne donne pas du tout le bon résultat dans ton fichier, il doit y avoir un problème.

    Dans la cellule F2, on doit récupérer la donnée dans I3
    Dans la cellule F3, on doit récupérer la donnée dans L4
    Dans la cellule F4, on doit récupérer la donnée dans J5
    Dans la cellule F5, on doit récupérer la donnée dans K3
     
  7. vmax01

    vmax01 XLDnaute Occasionnel

    Inscrit depuis le :
    17 Février 2008
    Messages :
    183
    "J'aime" reçus :
    7
    autant pour moi je n’avais pas compris ton raisonnement
    place cette formule en F2 et tu l’incréments vers le bas

    =DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);SOMME(C2:E2))

    bonne soirée.
     
  8. vatsyayana

    vatsyayana XLDnaute Nouveau

    Inscrit depuis le :
    17 Octobre 2014
    Messages :
    10
    "J'aime" reçus :
    0
    Ohhhh ça marche !!!! Trop contente ! Merci beaucoup à toi, tu me sauves ! :)
     
  9. vatsyayana

    vatsyayana XLDnaute Nouveau

    Inscrit depuis le :
    17 Octobre 2014
    Messages :
    10
    "J'aime" reçus :
    0
    Sais-tu comment éviter l'erreur #VALUE! quand les cellules avec le nombre de produits sont vides ?
    Ayant 3 tableaux comme ceux de l'exemple différents, j'ai additionné 3 fois la formule, ce qui fonctionne très bien, mais si une commande ne comporte pas un produit dans chacun des 3 tableaux, cela me met cette erreur.
     
  10. vmax01

    vmax01 XLDnaute Occasionnel

    Inscrit depuis le :
    17 Février 2008
    Messages :
    183
    "J'aime" reçus :
    7
    tu mets cette formule en F2 et incrémentation

    =SI(SOMME(C2:E2)=0;0;(DECALER($H$2;EQUIV(B2;$H$3:$H$6;0);SOMME(C2:E2))))

    bonne soirée
     
  11. vatsyayana

    vatsyayana XLDnaute Nouveau

    Inscrit depuis le :
    17 Octobre 2014
    Messages :
    10
    "J'aime" reçus :
    0
    Génial ! Merci beaucoup !
    bonne soirée à toi aussi ;)
     

Partager cette page