formule pour mfc

niki42

XLDnaute Occasionnel
bonsoir à tous


j'ai un petit problème à résoudre: je veux mettre une MFC dans une cellule. Cette MFC dépendra de la valeur d'une autre cellule.
il faut que les cellules de la colonne C se colorent en vert si les cellules de la colonne E ont une certaine valeur.
j'ai donc utilisé cette formule mais apparament il y a une erreur: =si(ou(1450015500;2950030500;4450045500))

je vous joins mon fichier

merci d'avance pour votre aide [file name=regcarbu.zip size=6164]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/regcarbu.zip[/file]
 

Pièces jointes

  • regcarbu.zip
    6 KB · Affichages: 18

andré

XLDnaute Barbatruc
Salut,

Essaie ceci, cela devrait fonctionner :

=OU(ET(E4›14500;E4‹15500);ET(E4›29500;E4‹30500))
Â+

EDITION :
Il manque des signes ‹ et › !
Il faut les remplacer par leurs équivalents clavier.

Message édité par: andré, à: 14/06/2006 19:51
 

JeanMarie

XLDnaute Barbatruc
Bonjoir

Attention à l'association des OU et des ET
=OU(ET(14500InférieurEgalE4;15500SupérieurEgalE4);ET(29500InférieurEgalE4;30500SupérieurEgalE4))
@+Jean-Marie

Remplace les commentaires par les symboles

Message édité par: JeanMarie, à: 14/06/2006 19:50

Message édité par: JeanMarie, à: 14/06/2006 19:52
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Et celle-ci :
=ABS(E4-ARRONDI(E4/15000;0)*15000) inférieur ou égal à 500
(tu remplaces 'inférieur ou égal à' par les signes)

Couleur verte quand E est à :
à 15000 plus ou moins 500
à 30000 plus ou moins 500
à 45000 plus ou moins 500
etc, tous les multiples de 15000 + ou - 500
 

niki42

XLDnaute Occasionnel
Bonjour

Je vous remecie pour votre aide.

J'ai testé et ça marche mais je voudrais comprendre pourquoi lorsque j'utilise la formule suivante ça ne marche. Est ce qu'il manque quelque chose ou y-at'il une erreur?

=SI(OU(1450015500;2950030500);'vidange moteur!!';'')

merci de m'éclairer
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Les ET et les OU et leurs parenthèses :
SI(OU(ET(cond1;cond2);ET(cond3;cond4));'vidange moteur!!';'')
SI(OU(ET();ET();ET();ET());faire;sinon)

Dans ton fichier, tu en as une autre (qui va jusqu'à la vidange des 45000 km, après, on jette la voiture)
et une autre, sans cette limite [file name=MefcNiki.zip size=6342]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/MefcNiki.zip[/file]
 

Pièces jointes

  • MefcNiki.zip
    6.2 KB · Affichages: 28

niki42

XLDnaute Occasionnel
Bonjour à tous

j'arrive enfin à te répondre Monique (hier soir pas de forum,arfff!).

en fait j'avais pas compris qu'il fallait utiliser les Ou et ET en même temps. je croyais que l'on utilisait le OU pour choisir et le ET quand on voualit tout

Finalement c'était mal expliqué sur mon bouquin ou alors c'est moi qui ait rien compris(si si c'est possible!!)

Bises à tous

@+

PS je reviens sur le fil si encore problème ou question
 

niki42

XLDnaute Occasionnel
Bonsoir

bon j'ai encore besoin de votre aide.

A ma formule je veux rajouter 'vidange moteur' qui apparait en blanc avec la couleur de cellule rouge.

j'ai mis ceci mais avec je n'ai pas 'vidange moteur' et en plus je n'ai plus la cellule qui se met en rouge.
voici la formule:
=SI(OU(ET(E15>14500;E1529500;E1544500;E15<=45500));'vidange moteur!!';'')

si une âme charitable passe par là....
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Ta formule a été mangée par le forum

Pour la C15, celle-ci marchait, non ?
=SI(OU(ET(E15 sup ou égal à 14500;E15 inf ou égal à 15500);ET(E15 sup ou égal à 29500;E15 inf ou égal à 30500);ET(E15 sup ou égal à 44500;E15 inf ou égal à 45500));'Vidange moteur!!';'')

Je préfère celle-ci (elle va plus loin que la vidange des 45000) :
=SI((ABS(E15-ARRONDI(E15/15000;0)*15000) inf ou égal à 500)*(E15>0);'Vidange moteur!!';'')

* * Tu remplaces ' inf ou égal à ' et ' sup ou égal à ' par les signes appropriés

Pour le format conditionnel :
tu choisis 'La valeur de la cellule est ' puis 'égale à '
puis tu tapes ='Vidange moteur!!'
et tu choisis ton format par les onglets et 2 fois OK
 

niki42

XLDnaute Occasionnel
bonjour à tous

ok Monique pour ta formule.
En fait j'utilisais ta formule dans la mise en forme condtionnelle: la formule est puis la formule, c'est pour ça que ça n'allait pas.

sinon ta formule est super mais est-ce que tu pourrais me la traduire en 'français' parce que je ne suis pas sûre d'avoir tout compris :S

merci encore pour ton aide
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Je vais essayer de causer français

=SI((ABS(E15-ARRONDI(E15/15000;0)*15000) inf ou égal à 500)*(E15>0);'Vidange moteur!!';'')

=ARRONDI(E15/15000;0)*15000
arrondi au multiple de 15000 le plus proche

E15-ARRONDI(E15/15000;0)*15000
donne la différence entre les km au compteur et ce multiple de 15000

ABS(E15-ARRONDI(E15/15000;0)*15000)
donne la valeur absolue de cette différence (que l'on soit avant ou après, aucune importance, il n'y a pas de signe - ni de signe +)

(ABS(E15-ARRONDI(E15/15000;0)*15000) inf ou égal à 500)
renvoie VRAI ou FAUX : différence inférieure ou non à 500

*(E15>0)
renvoie aussi VRAI ou FAUX

VRAI équivaut à 1 et FAUX à 0
VRAI * VRAI = 1
VRAI * FAUX = 0

=SI((ABS())*(E15 pas vide)=1; message; sinon rien)
ça, ça suffit :
=SI((ABS())*(E15 pas vide); message; sinon rien)

Dans le format conditionnel :
=((ABS())*(E15 pas vide)=1
ça, ça suffit :
=((ABS())*(E15 pas vide)
 

niki42

XLDnaute Occasionnel
Re

Ok Monique ça va j'ai capté.

Excuse-moi mais il y a des fois où c'est pas évident à traduire et comme je dis souvent: vaut mieux comprendre ce qu'on fait plutôt que de répéter bêtement.

En attendant je te remercie pour le bonus de la leçon

:) :)

PS:remarque je pense que ça peut profiter à d'autres parce que je suis sûre que l'on est assez nombreux à ne pas t'arriver à la cheville en ce qui concerne Excel et les formules


:lol: :lol: :lol: :lol:
 

Statistiques des forums

Discussions
291 501
Messages
1 915 830
Membres
178 990
dernier inscrit
shadowtheone
Haut Bas