Microsoft 365 FORMULE pour gérer une somme cumulative si doublons en jour ouvré

The_benjiboy

XLDnaute Nouveau
Bonjour à tous,
je viens vers vous car je suis embêté avec une formule excel !!!
je cherche à calculer une date de fin fin de tâche en prenant en compte la personne à qui la tâche est attribuée :

en donnée, je dispose, des personnes affectées (colone A), de la date de fin de tâche prévue (colone B), du concat des deux (colone C).
l'idée est que si dans la colone C, il y a des doublons, alors dans la colone D, ajouter 5 jour ouvrés à chaque ligne concernées succéssivement.

éxemple :

1034634

en rouge les fameux doublons (la condition).
en jaune les résultat que je cherche à calculer de façon "automatique".
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour The benjiboy,

un essai en fichier joint la formule n'as pas besoin de la colonne C, par contre si tu devais faire une nouvelle demande merci de poster un petit fichier on ne peut pas tester nos proposition sur une image

Cordialement
 

Fichiers joints

The_benjiboy

XLDnaute Nouveau
SUPER !!!!! ça fonctionne parfaitement, vous êtes mon héro !
Je n'aurais jamais trouvé cela seul.
Maintenant je vais bien éplucher cette formule pour la comprendre parfaitement.

Merci beaucoup
 

Jocelyn

XLDnaute Barbatruc
re,

je ne sais pas ce qui ne va pas mais j'ai de mon coté rajouté de données et tout a l'air de fonctionner

Cordialement

au cas ou explique moi la façon dont tu as effectué les modifs
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
re,

Une autre solution qui n'utilise pas la fonction max(si()) et qui n'a donc pas besoin de la validation matricielle a voir en colonne D

Cordialement
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
re,

je ne sais pas comment tu fais il n'y a a priori aucune raison que la formule ne fonctionne pas je penses que cela vient du max(si()) fait un test avec la formule du fichier benjiBoy-2 bis

VB:
=SI(SOMMEPROD(($A$4:A4&$B$4:B4=$A4&$B4)*1)=1;$B4;SERIE.JOUR.OUVRE($B4;5*(SOMMEPROD(($A$4:A4&$B$4:B4=$A4&$B4)*1)-1)))
cette formule n'a pas besoin de validation matricielle

Cordialement
 

The_benjiboy

XLDnaute Nouveau
j'ai tester la nouvelle proposition et cela ne fonctionne toujours pas; je dois faire quelque chose de travers, mais je ne comprend pas pourquoi cette formule fait référence au résultat de la première formule.
voici mon fichier réel (il y a peu être autre chose dans mon fichier qui empeche le bon fonctionnement), la colonne qui m'intéresse est la K.
 

Fichiers joints

The_benjiboy

XLDnaute Nouveau
Super !!! cela fonctionne parfaitement !!
j'ai re-vérifier 40 fois, je ne comprend pas pourquoi ca ne fonctionnait pas ...

Merci beaucoup en tout les cas.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas