formule pour faire la somme par rapport un critère dans une autre colonne

Jperret

XLDnaute Nouveau
Bonjour,

je recherche une formule qui me permettrait de faire la somme par rapport un critère dans une autre colonne.

Exemple :
A B C
Mr X 15 -5%
Mr Y 25 + 10%
Mme L 35 +12.5%
Mme P 30 -45%
Mr F 10 -26%
Mr D 45 -18%
Mme R 20 + 32%

J'aimerai avoir une formule qui puisse me permettre d'obtenir le total des valeurs de la colonne B uniquement pour celles dont le % en colonne C est négatif

Au final, j'aimerai obtenir 100 (15 + 30 + 45)

Merci par avance de votre aide
 

Jperret

XLDnaute Nouveau
J'aimerai dans le fichier joint faire apparaitre dans la cellule D20 la somme des valeurs la colonne B uniquement pour celles qui sont en <0% dans la colonne C et ainsi obtenir 1491206. Merci de votre aide
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Bonjour,
Le sommeprod fonctionne si on n'inclue pas les titres :
=SOMMEPROD(($C$2:$C$19<0)*($B$2:$B$19))
le somme.si fonctionne aussi (quand on lit correctement l'énoncé :()
=SOMME.SI($C$2:$C$19;"<0";$B$2:$B$19)
Cordialement
 

Haut Bas