Formule pour comptage avec plusieurs conditions

bigfoot177

XLDnaute Nouveau
Bonjour,

J'ai besoin de votre aide concernant un tableau comme suivant:

19/01/2015 15:00
22/01/2015 13:25
04/02/2015 14:45
12/02/2015 15:30
12/02/2015 15:30
12/02/2015 15:30
13/02/2015 15:00
13/02/2015 15:00
20/02/2015 14:30
06/03/2015 12:30

Il faudrait que j'arrive avec une seule formule à déterminer le nombre de dates uniques (sans les doublons), et par mois (pas possibilité de séparer en plusieurs colonnes pour les mois de janvier février et mars).

Merci d'avance pour votre aide.
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Re : Formule pour comptage avec plusieurs conditions

Bonsoir bigfoot177 et bienvenue sur XLD :),

Voir un essai dans le fichier joint utilisant la formule matricielle :
Code:
=SOMME(N(FREQUENCE(SI(MOIS($A$1:$A$10)=E2;ENT($A$1:$A$10));SI(MOIS($A$1:$A$10)=E2;ENT($A$1:$A$10)))>0))
Formule matricielle: Elle doit être validée par la combinaison des touches Ctrl+Maj+Entrée au lieu de la seule touche Entrée comme une formule classique.
Si la validation matricielle est correcte, alors Excel entoure la formule d'accolades {=.......}.
Chaque fois que cette formule sera modifiée, la validation devra se faire par Ctrl+Maj+Entrée. Les accolades apparaissent à la validation et ne doivent pas être saisies au clavier.
NOTA: j'ai uniquement tenu compte de la date (comme c'était dit dans l'énoncé) et je n'ai pas pris en compte l'heure.

12/02/2015 15:30:00 et 12/02/2015 15:31:00 compteront pour une date et non pas deux.
 

Fichiers joints

Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas