Formule pour Calculer les heures de nuit

  • Auteur de la discussion hectine
  • Date de début
H

hectine

Guest
Bonjour

Voila, j'utilise excel pour mes feuilles d'heures et tout est automatisé (le calcul des paniers, des heures faites dans la journée etc...) mais il y a un truc que je n'arrive pas à faire, c'est la formule pour calculer les heures de nuit.

Ces heures de nuit partent de 21h00 à 06h00.

Il faudrait donc que lorsque j'entre par exemple en colonne A (début de travail) et en colonne B (fin de travail), en C j'obtienne les heures de nuit.

Exemple :

A B C

18 03 6
19 21 0
16 22 1
02 08 4

etc...

Qui serait capable de me faire cette formule que j'insèrerais en colonne C (heures de nuit) ?
Merci.
 
J

jmps

Guest
Salut hectine,

J'ai à peu près compris ta question, mais ton exemple me "confuse"...

18h00 à 3h00 = 9 heures et non 6.
19h00 à 21h00 = 2 heures et non 0.
Etc...

Peux-tu préciser ?

José
 
H

hectine

Guest
18h à 03h = 09 heures de travail oui. Mais 6h de nuit.
19h à 21h = 2 heures de travail oui. Mais 0h de nuit.

Car heures de nuit = 21-06
 
J

jmps

Guest
Ok hectine,
excuse-moi j'avais pas bien lu ta question...

Laisse-moi 10 minutes et je reviens...

José
 
M

Monique

Guest
Bonjour,

Tu as une formule qui fait ça dans le classeur "Dates et Heures",
dans la feuille DuréeBornesNuit
Il est à télécharger ici :
<http://www.excel-downloads.com/html/French/fichiers/programmation-date_maj-2.htm>
 
J

jmps

Guest
Hello Monique...

Pas eu le temps de réfléchir. T'es la meilleure !

Désolé Hectine, je ne suis qu'un newbie...
J'espère que Momo a réglé ton problème ;°)

José
 
H

hectine

Guest
Non. au contraire, le fichier contient du visual basic, ça a tout planté, j'ai perdu mes feuilles de travail. C'est la fête... >:eek:/

C pas grave j'irais demander ailleurs.
merci quand même. >:-/
 
J

jmps

Guest
Re Hectine,

Que veux-tu dire par "Tout planté" et "Perdu mes feuilles de travail" ?

José
 
H

hectine

Guest
ca veut dire que j'ai téléchargé le fichier donné par Monique, je l'ai ouvert, excel m'a informé qu'il y avait une erreur de visual basic, j'ai fait ok, tout a planté ; Excel s'est fermé et ça a fermé toutes mes feuilles que je n'avais pas encore enregistré !

Résultat g plus rien. Faut tout que je refasse. C'est la fête.

@++
 
C

Celeda

Guest
Bonsoir,

De plus si on n'active pas les macros, les pages fonctionnent correctement.

Donc ce ne peut être DEH qui a fait planter le système.
Contrôle comment tu es vis-à-vis des macros, mais je peux te garantir
que ces macros sont hors de cause.

Celeda
 
C

Celeda

Guest
Bonsoir

Re,
je ne comprends pas où peut se trouver l'erreur
c'est d'ailleurs la première fois que l'on nous mentionne cette situation
et je suis bien chagrinée pour toi

N'hesite pas à nous envoyer ton fichier sur moniqueceledaxld@yahoo.fr
si on peut t'aider on le fera bien volontiers

Encore désolée,

Celeda

ps : sur quelle version travailles-tu, svp
 
J

jmps

Guest
Hectine,

Je suis désolé pour le boulot perdu (sincèrement).

Monique n'y est pour rien. Elle a seulement essayé de t'aider.
Elle ne peux pas être derrière toi pour savoir si tu as sauvegardé ton fichier avant de faire des tests...

Et comme tu dis : "C'est la fête". Moi je rajoute : "C'est ta faute".
Quand on fait des tests, on sauvegarde régulièrement son boulot...

Encore désolé Hectine... Et si tu vas voir ailleurs, n'hésite-pas à nous communiquer les adresses des sites qui te feront pas planter ton Excel si tu n'as pas sauvegardé.

Bonne chance Hectine !

Nonmédéfois...

José
 
C

Celeda

Guest
Bonsoir,

Re Hectrine,
Je pense subitement à quelque chose qui pourrait t"aider pour ton travail,
va voir dans les fichiers temporaires si tu n'as pas conservé une version antérieure
à celle que tu as perdue.
On ne sait jamais………….
Celeda
 
M

Monique

Guest
Re,

Je n'avais encore jamais fait planté quelqu'un.
Mais ce fichier a été téléchargé tant de fois sans aucun problème qu'il ne peut pas être la cause.

Sans fichier, maintenant.
21:00 en A1, 06:00 en B1
Heure de début du travail en A6
Heure de fin du travail en B6
=SI(ET(A6>=B6;A6<=A1;A6<>0;B6<>0);MOD(B1-A1;1)-SI(B6<=B1;B1-B6)
+SI(A6<=B1;B1-A6);SI(ET(A6>=B6;A6>A1;A6<>0;B6<>0);MOD(B1-A1;1)-(A6-A1)+SI(B6>=A1;B6-A1)-SI(B6<B1;B1-B6);SI(ET(A6<B6;ESTNUM(A6);B6<>0);0+SI(ET(A6<=B1;B6<=B1);B6-A6)+SI(ET(A6<=B1;B6>B1);B1-A6)+SI(B6>=A1;B6-A6-SI(A6<=A1;A1-A6));"")))

Ou bien, si on donne un nom aux cellules qui contiennent 21:00 et 06:00
=SI(ET(A6>=B6;A6<=debut_tarif;A6<>0;B6<>0);MOD(fin_tarif-debut_tarif;1)-SI(B6<=fin_tarif;fin_tarif-B6)
+SI(A6<=fin_tarif;fin_tarif-A6);SI(ET(A6>=B6;A6>debut_tarif;A6<>0;B6<>0);MOD(fin_tarif-debut_tarif;1)-(A6-debut_tarif)+SI(B6>=debut_tarif;B6-debut_tarif)-SI(B6<fin_tarif;fin_tarif-B6);SI(ET(A6<B6;ESTNUM(A6);B6<>0);0+SI(ET(A6<=fin_tarif;B6<=fin_tarif);B6-A6)+SI(ET(A6<=fin_tarif;B6>fin_tarif);fin_tarif-A6)+SI(B6>=debut_tarif;B6-A6-SI(A6<=debut_tarif;debut_tarif-A6));"")))
 
H

hectine

Guest
Si c'est bon, j'ai pu récupérer le fichier par les trucs temporaires.

Un gars sur un forum informatique m'a donné ça ;

=SI(A4>=21;SI(B4>=21;B4-A4;SI(B4<=6;B4+24-A4;6+24-A4));SI(A4>6;SI(B4>=21;B4-21;SI(B4>6;6+24-21;B4+3));SI(B4>6;6-A4;B4-A4)))

Problème ; il faudrait que la formule indique 0 quand il n'y a pas d'heures de nuit. au lieu de ça, elle me marque les heures classiques. Par exemple

21-24 : elle marque bien 3. mais 07-19 : elle me marque 12 au lieu de 0.
 
M

Monique

Guest
Re,

Tes heures de nuit sont en place.
L'heure de début et de fin des nuits est sur une feuille à part.
Cellules nommées D et F pour raccourcir la formule.

Le format des heures est changé, tu peux supprimer toutes les colonnes qui te donnaient "h" ou rien
J'ai enlevé le format texte partout, on se sert de vrais nombres.
Il y a un truc que je n'ai pas compris, c'est le total des heures de dimanche multiplié par 40
Dans ces totaux, la formule est aussi modifiée :
on fait le total de tout, tout, tout même les sous-totaux, et on divise par 2.

Tu as une colonne "Heures jours fériés"
Pour faire ce compte, il faudrait avoir de vraies dates en colonne B
et une plage de fériés quelque part dans ton classeur.
Est-ce que tu veux un compte de fériés ?
Si oui, il faudra enlever les lignes qui séparent les semaines et faire les totaux hebdo sur le côté et non sous chaque semaine.
Tu as un exemple ici (mais tu ne voudra peut-être pas le télécharger) :
La page "Calendrier Etat Heures" de Autres Formules III"
<http://www.excel-downloads.com/html/French/fichiers/programmation-date_maj-1.htm>
 

Fichiers joints

H

hectine

Guest
Salut.

Merci pour la formule. Mais est il possible de l'adapter sans rien changer dans la feuille ? Je veux dire, en gardant l'exemple que je t'ai envoyé dans lequel j'insère la deuxième page. De sorte qu'on obtiendrait un chiffre rond comme 20 pour 20h ou 20,5 pour 20h30. Car si je reprends mon exemple, que je colle ta deuxième page et que je copie ta formule et la place dans la colonne appropriée, j'ai des ####.

Penses tu pouvoir l'adapter ?

=SI(ET(D2>=E2;D2<=D;D2<>0;E2<>0);MOD(F-D;24)-SI(E2<=F;F-E2)+SI(D2<=F;F-D2);SI(ET(D2>=E2;D2>D;D2<>0;E2<>0);MOD(F-D;24)-(D2-D)+SI(E2>=D;E2-D)-SI(E2<F;F-E2);SI(ET(D2<E2;ESTNUM(D2);E2<>0);0+SI(ET(D2<=F;E2<=F);E2-D2)+SI(ET(D2<=F;E2>F);F-D2)+SI(E2>=D;E2-D2-SI(D2<=D;D-D2));0)))+SI(ET(I2>=J2;I2<=D;I2<>0;J2<>0);MOD(F-D;24)-SI(J2<=F;F-J2)+SI(I2<=F;F-I2);SI(ET(I2>=J2;I2>D;I2<>0;J2<>0);MOD(F-D;24)-(I2-D)+SI(J2>=D;J2-D)-SI(J2<F;F-J2);SI(ET(I2<J2;ESTNUM(I2);J2<>0);0+SI(ET(I2<=F;J2<=F);J2-I2)+SI(ET(I2<=F;J2>F);F-I2)+SI(J2>=D;J2-I2-SI(I2<=D;D-I2));0)))
 
H

hectine

Guest
C'est bon !!

Formule finalisée. J'insère deux colonnes entre << TOTAL vacation >> et << dont nuit >>. Dans la première je mets :

=SI(D2>=21;SI(E2>=21;E2-D2;SI(E2<=6;E2+24-D2;6+24-D2));SI(D2>6;SI(E2>=21;E2-21;SI(E2>6;SI(E2<D2;6+24-21;0);E2+3));SI(E2>6;6-D2;E2-D2)))

Dans la seconde :

=SI(I2>=21;SI(J2>=21;J2-I2;SI(J2<=6;J2+24-I2;6+24-I2));SI(I2>6;SI(J2>=21;J2-21;SI(J2>6;SI(J2<I2;6+24-21;0);J2+3));SI(J2>6;6-I2;J2-I2)))

En fait ce sont les même formules décalées.

Puis dans Dont nuit, j'additionne les deux ci-dessus. Puis je rétrécis les deux colonnes à 0. Ainsi, on ne les voit pas. Et ça permet de calculer les heures de nuit sur deux vacations. :))

Bonne soirée et merci.
 
M

Monique

Guest
Re,

Ce n'est pas la formule qui serait à adapter, mais l'affichage.
Tu as plusieurs solutions.
Est-ce que tu as supprimé les colonnes qui contenait le "h" et qui ne servent plus ?
Tu élargis la colonne.
Tu choisis une police plus petite.
Tu changes le format de la cellule :
[=0]"";0,00"h"
(un espace en moins)
[=0]"";0,0" h"
(un 0 en moins)
[=0]"";0,0"h"
(un 0 et un espace en moins)
Si tu veux imprimer, tu joues sur le zoom
Colonne des jours, tu peux écrire Lun, Mar, Mer, etc
 

Discussions similaires


Haut Bas