Formule permettant de lister les membres d une meme occurence

olivez

XLDnaute Nouveau
Bonjour,

QQ'un pourrait-il m'aider ?
J'ai besoin que dans la colonne A apparaissent tous les employes qui sont du 'Front Office' ou tous du 'POMEC' et que l'on trouve a droite sur cette meme feuille, en fonction de ce que l'on choisit dans la cellule K3.

Merci pour votre aide !!

Olivez
 

Fichiers joints

Brigitte

XLDnaute Barbatruc
Re : Formule permettant de lister les membres d une meme occurence

Bonjour,

Je viens de retrouver un fichier "trouver occurences" qui me semble particulièrement répondre à ta demande. Je n'ai pas le temps de m'y replonger, les formules sont un peu trop obscures pour moi mais diablement efficaces.

Je te laisse regarder, et puis d'autres te trouveront peut être encore mieux..

Sinon c dans la case jaune qu'il y a une liste déroulante ou on choisit "paul" ou autre chose.... comme toi qui veut choisir ton Front Office ou ton Pomec... et c à droite que la liste se fait.

Bon courage.
 

Fichiers joints

Brigitte

XLDnaute Barbatruc
Re : Formule permettant de lister les membres d une meme occurence

Et voici avec tes données, ca marche. Mais je me suis contentée de mettre tes données dans MON tableau (enfin celui que j'ai mis dans le post précédent)...

Pour installer les formules, les adapter à TON tableau, j'ai bien cherché mais ca pose souci, vu que tu as des colonnes où les données ne sont pas de même type selon les lignes... donc une colonne n'est pas dévolue à un type de donnée...

Mais c'est pour te montrer que ca marche, enfin si j'ai tout compris de ce que tu souhaites.
 

Fichiers joints

Brigitte

XLDnaute Barbatruc
Re : Formule permettant de lister les membres d une meme occurence

Je suis en train d'avancer sur ton fichier, tu veux le début ?

Je coince sérieusement de toute manière, car vu la disposition de tes données dans ton fichier, ca correpond pas du tout à mon fichier exemple (enfin celui que j'ai posté et que je dois à je ne sais qui)...
 
Dernière édition:

JeanMarie

XLDnaute Barbatruc
Re : Formule permettant de lister les membres d une meme occurence

Bonjour

Voici une formule très peu utilisée, elle impose d'avoir la base triée par la colonne dept_name.
=SI(NB.SI(O:O;K$3)>LIGNES($11:11);INDIRECT("N"&(LIGNES($11:11)+EQUIV(K$3;O:O;0)-1));"")
Formule à mettre dans la cellule A11 et tu fais un glisser/déposer vers le bas.

@+Jean-Marie
 

Monique

XLDnaute Barbatruc
Re : Formule permettant de lister les membres d une meme occurence

Bonjour,

Une autre à essayer :
=SI(NB.SI(O$10:O$20;K$3)<LIGNES(A$11:A11);"";DECALER(N$1;PETITE.VALEUR(SI(O$10:O$20=K$3;LIGNE(O$10:O$20));LIGNES(A$11:A11))-1;))

à mettre en A11, à valider par ctrl, maj et entrée
et à copier coller vers le bas
 

Monique

XLDnaute Barbatruc
Re : Formule permettant de lister les membres d une meme occurence

Re,

Sans smiley :

=SI(NB.SI(O$10:O$20;K$3)<LIGNES(A$11:A11);"";DECALER(N$1;PETITE.VALEUR(SI(O$10:O$20=K$3;LIGNE(O$10:O$20));LIGNES(A$11:A11))-1;0))
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas