Formule NB.SI à adapter ?

pepeye66

XLDnaute Nouveau
Bonjour à tous,
Dans le classeur excel ci joint je crée une feuille qui servira de modèle pour créer des fiches de contact.
Dans la partie haute de la feuille les infos génériques (saisies ou récupérées)
Dans la partie basse le déroulé des contacts.
Dans le déroulé des contacts la colonne E "Contact" comprend 2 choix: "Abouti" "non abouti"
Dans la partie haute je voudrais réaliser une statistiques des contacts aboutis et non aboutis (cellules en fond bleu)
Je voudrais qu'en choisissant une année (en D11) le nombre des contacts aboutis (D12) et non aboutis (D13) s'incrémente automatiquement.
Mais voilà, je ne sais comment faire et s'il faut entrer une macro...Je nage !
Pouvez vous m'aider SVP ?
Merci
 

Fichiers joints

Efgé

XLDnaute Barbatruc
Re : Formule NB.SI à adapter ?

Bonjour pepeye66

Je n'aurais certainement pas le temps de me pencher sur ton classeur, mais si tu veux que quelqu’un puisse faire quelque chose, il faudrait un minimum de données avec ta feuille de présentation.

En l'état ton exemple est "un peu trop anonyme" :D

Cordialement

EDIT : Bonjour
djidji59430 :)
J'avais pensé que les listes n'étaient là que pour faire des listes de validations.....
 
Dernière édition:

Chris401

XLDnaute Accro
Re : Formule NB.SI à adapter ?

Bonjour à tous

Essaye :
Code:
=NB.SI.ENS(B20:B169;$D$11;E20:E169;"Abouti")
OU
Code:
=SOMMEPROD((B20:B169=$D$11)*(E20:E169="Abouti"))
Cordialement
Chris
 

pepeye66

XLDnaute Nouveau
Re : Formule NB.SI à adapter ?

Bonjour,
Merci pour cette remarque, j'ai simulé quelques saisies pour faire vivre la feuille de suivi.
Espérant que ce sera explicite.
;)
 

pepeye66

XLDnaute Nouveau
Re : Formule NB.SI à adapter ?

@ Chris401:
Bonjour,
Merci pour cette réponse qui fonctionne bien !
J'ai récupéré ta première formule concernant les contacts "abouti": OK - je l'ai transposée pour les "Non Abouti" : OK
J'ai simulé des saisies pour d'autres années et ça fonctionne bien !!
Mille mercis :eek:
C'est sympa d'aider.
:)
 

pepeye66

XLDnaute Nouveau
Re : Formule NB.SI à adapter ?

Pour ma formation excel je suis allé chercher des infos sur la fonction NB.SI.ENS que je ne connaissais pas et qui est bien pratique: Je la réutiliserai !
MERCI.
;)
 

djidji59430

XLDnaute Barbatruc
Re : Formule NB.SI à adapter ?

Merci pour cette réponse...Mais qui ne fonctionne pas :(
Je joins ton classeur avec quelques exemples de saisies pour vérifier tes formules...Et non, ça ne comptabilise pas.
Une idée ?
Merci.
Forcement, ce n'est pas la que je comptabilisais. Avec plus d'explications .......
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas